Cannot change keyboard language, even through control panel!


Joined
Sep 7, 2014
Messages
7
Reaction score
0
Hi, I am trying to change the input language from English (US) back to English (UK) on my Windows 7 computer. For some reason, it just changed on its own and I have no idea why!

When I go to the Region and Language settings and then click 'Change keyboards', I get to the 'Text Services and Input Language' dialog box. However, NO languages appear whatsoever! At the bottom of this request is a picture explaining what I mean.

Also, on the 'Welcome screen and new user accounts settings' dialog box (which I got to through the admin tab on the Region and Language settings), it's says 'setting could not be read' next to input language. Another picture will be at the bottom showing this.

Please could you help me? I don't like it when I type the '@' key and it comes up with the ' " ' symbol!

Thank you,
Kazaaak.

heeeeeeeeeeeelp!.JPG
Capture.JPG
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
Best guess, your registry is corrupt. Did you run any registry cleaners or "Speed up your PC" tools lately?

You could try System Restore *type system restore into the Start-Search bar) to a restore point prior to the problem.
 

Shintaro

Moderator
Joined
Mar 1, 2012
Messages
2,137
Reaction score
252
I would suggest that you also run check disk as well:

Just so you know chkdsk (Check Disk) needs to be run on a restart so that the whole disk can be checked.


  1. Click on the Start button and type in cmd.
  2. In the list you will see cmd.exe.
  3. Right click on Cmd.exe and select "Run as Administrator"
  4. Type in the following chkdsk /r /f (See the image below)



  1. Type in Y and press enter.
  2. Reboot your computer. On the restart chkdsk will check the hard disk for errors.
  3. There will be an event logged.


Event Viewer
  1. Press the Windows Key + R and type in eventvwr
  2. In Event Viewer click on Windows Logs -> Application.
  3. Right click on "Application" and select "Find"
  4. Type in "chkdsk" (without the quotes)
  5. When it finds the event, right click on the event and select Copy -> "Copy Details as Text" and paste it to the forum.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
I have marked this solved.

NOTE: I have edited your post and included the direct link to the Microsoft information page. Please do not post redirecting advert links such as bit.ly.

UPDATE: I got your message that the issue is still not fixed so I changed the status back to unsolved.
 
Last edited:

Shintaro

Moderator
Joined
Mar 1, 2012
Messages
2,137
Reaction score
252
So if the issue is still not fixed, did you run check disk?
Can you please post the results.
 
Ad

Advertisements

Joined
Sep 7, 2014
Messages
7
Reaction score
0
I ran the check disk, I'll get the results in a short while, I am kinda busy. Thanks for bearing with me.

Edit: The results are below
 
Last edited:
Joined
Sep 7, 2014
Messages
7
Reaction score
0
Sorry for the delay! I've got the results up on pastebin here: http://pastebin.com/NxYnCdiK.

There was an optional update available (I download all da updates =D)(http://support.microsoft.com/kb/2970228) which was to support the new currency symbol for the Russian ruble. Today, when I checked the languages control panel I found that 4 new languages which I could 'add'. However after checking the layout previews I saw that there were actually no characters on the keys, just the tab, caps, shift, backspace and enter keys. See the image below.

Also no registry cleaners or 'speed up my PC tools' were run on this computer.

 
Last edited:

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
Are you running Windows Ultimate or Enterprise? 32 or 64-bit?

Have you tried uninstalling & then installing the languages again?
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
Home Premium doesn't officially support changing languages, so my idea of uninstalling & reinstalling the languages completely won't help.

And you said adding keyboard languages doesn't work.

As I said in the beginning I suspect your registry has been corrupted. If you have any restore points then I suggest you use "System Restore" to go back to a restore point prior to the problem. Or if you have an old system back-up from when it was working then you could restore to that.

If you don't have any of those then you could try a system repair from the W7 installation disk, though that only fixes windows files so if I'm right and it is a registry problem then that won't help. Still on the small chance it is a corrupt system file, you should try it.

So at that point if it still won't work then my suggestion would be to reinstall W7 completely.
 
Ad

Advertisements

Joined
Sep 7, 2014
Messages
7
Reaction score
0
I will try doing the system restore. Also, I don't have the W7 installation disk because I bought the computer from HP and it came with the OS. I think the proper term is OEM, but I am not sure.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
We have links for W7 ISOs in some languages though I do not believe that includes Russian. But for System Repair purposes you could burn the English version to a DVD. Links to the W7 SP1-U ISO are HERE and if you need DVD burning software that understands an ISO image I suggest IMGBurn from our Freeware DB.
 
Joined
Sep 7, 2014
Messages
7
Reaction score
0
Much appreciated. I don't have any restore points that actually go as far back as I need it to, so that's not great! I will burn the ISO to a disk and try it out, thanks for your help. I'll update you after I finish downloading it (a long while!).
 

Shintaro

Moderator
Joined
Mar 1, 2012
Messages
2,137
Reaction score
252
If you bought the computer from HP there will be a restore partition. You create your CD/DVD/USB via HP support Assistant.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,331
Reaction score
1,584
If it has a restore partition you normally don't need the DVD at all, for a total reinstall just select System Recovery at boot up and restore the system to factory settings. Just be sure you backed up all your data to an external drive or large USB flash drive first.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top