Windows 7 does not save network login credentials (username and password)

Joined
Sep 1, 2011
Messages
1
Reaction score
0
I found a fix

Don't know if this has been posted here already, I didn't get through every post.

I didn't come up with it obviously, but after searching endlessly I finally found a fix that worked for me. Sometimes when searching Google and all the other blogs it really makes a difference what you're question is.

Anyway I thought on my last search to include HomeGroupUser$ as apart of my issue with the Credential Manager forgetting the settings.

Exact Search: credential manager forgets HomeGroupUser$

And I came across a site that seemed to indicate that the HomeGroup was the issue. Well for me, as it turned out, it was.

To fix it I had to remove / delete all my Windows 7 computers from the Home Group, then build a new one. Once I did that the system stopped reverting back to 'incorrect' settings.

One of the things I couldn't wrap my head around was that even after deleting Credential Manager Credentials, they would invariably be right back to where they were after a reboot. Turns out that with the Home Group all the machines kind of handshake all that information. So by deleting and redoing the Homegroup on all machines, problem solved.

Oh, last but not least, when mapping the drive, it won't create new Credential Manager settings unless you click the 'Connect using different credentials' checkbox.

Hope this helps anyone else that all other solutions wouldn't work for. Thanks.

Igorian
 
Last edited:

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
I read GopherBaroque's link. In it he says:
"Fixing the problem requires editing the group policies. ..."
But then, he explains how to fix the issue for Win7 Pro users using gpedit.msc. Since I'm on Win7 Home Premium, I don't have gpedit.msc, so I'll need to edit my registry by hand. The article only gave a warning that editing the registry might be dangerous: it didn't actually explain what changes to make.
Is there a resource for this information anywhere?
Robynsveil, I can not promise it has the resource you need but something was recently posted which gives much of the functionality of the Group Policy Editor to 32-bit Home Premium and it may help with this setting you need.
 
Last edited:
Joined
Apr 17, 2012
Messages
1
Reaction score
0
Last edited:
Joined
Apr 25, 2012
Messages
1
Reaction score
0
I followed redhotorange's instructions and it did not work the first time. However, I tried again, albeit in not exactly the same sequence, and it did work. Many thanks, therefore.

The key to success ifs to persuade W7HP to change the Persistence from "logon session" to "enterprise" in the credential. Therefore, you can check if the sequencing has had the desired effect.
 
Joined
May 5, 2012
Messages
1
Reaction score
0
I have followed this thread and now have my mapped dives logging on after a re-boot, thanks for all the help.:)
One thing that remains is I have to click on the drive to make it readable by WMC.
The drive is logged on but it has a red X until i click on the icon.
Hope you can help. Steve
 
Joined
Sep 12, 2012
Messages
1
Reaction score
0
Login for that nasty Login request!

Hi,

This was a solution that I found when having the log in request pop up. The issue, if it is the same, is the log in screen pops up when you are trying to access the shared whatever and none of your log-in information works.

I found out by double clicking my computer, and under the network section on the left hand side, double click the computer you are trying to connect to.

When the log in screen pops up, type in "admin" with no password and enter. This allowed me access to all the things I was trying to share. I don't know how to change this log in requirement yet or how to disable it.

Hope this might help.
 
Joined
Sep 13, 2013
Messages
1
Reaction score
0
Go to properties of the network.
Select options tab.
Uncheck prompt for user name,password etc.
It worked for me! gud luck! :)
 
Joined
Jun 24, 2014
Messages
1
Reaction score
0
I just signed up so I could post the simplest solution:


  1. Go to: Control Panel > User Accounts and Family Safety > Manage Windows Credentials
  2. Expand each device listed by clicking the down arrow
  3. Delete all the credentials by selecting "Remove from vault"(to make things simple)
  4. Create new credentials for each network by entering the IP address of the device you're trying to connect to. For example, most internal IP addresses start with 192.168.1.xx. The last two digits vary with each device. It could be 192.168.1.1, 192.168.1.16, etc. Enter this address in the "Internet or network address" field.
  5. Enter your username and password (don't have to enter computer name, slashes, etc)
  6. Try to connect to the network. It will now work.
  7. To double check, restart your computer. The credential will still be remembered.
I tried to write down the simplest instructions. Obviously, there is more depth to this and alternative solutions, but this one works. The issue is 1.You either did not enter your credential in the correct format or 2.You have corrupted/duplicate credentials. There is no sequence required. We usually think that if something works, the sequence must have mattered.
Thank you.

This is such a simple and elegant solution. It works very well for me - even after reboots without having to reenter userid and password. It even picks up files on a remote drive from the history in Word and Excel. It has solved such a pain!
 
Last edited:

Shintaro

Moderator
Joined
Mar 1, 2012
Messages
2,137
Reaction score
252
RuthHartzell,

Please start a new thread and outline the problems you are having.
 
Joined
Oct 15, 2014
Messages
1
Reaction score
0
Hi,
This problem was driving me nuts, but I've found a combination of hints that worked. In my case it was accessing a shared printer on another computer on the same network. Each time I would restart the remote machine it would lose the credentials and prompt me again before I could print a document.

After going round in circles for hours, deleting credentials just to have them miraculously re-appear on their own I noticed that the username being automatically created was HomeGroupUser$. Even after I would delete it and clear all the credentials entries. I wondered if it was the HomeGroup feature that was messing with the credentials. Sure enough it was.

I'm using Windows 7 Professional 64 bit on both machines, but this fix should apply to Home Editions as well.

1) Run services.msc
2) Scroll down to HomeGroup Listener and HomeGroup Provider.
3) Stop each of the services and disable them from starting.
4) Close services.msc
5) Open Control Panel and then Credentials Manager.
6) Under the Windows Credentials section, select all the credentials and click Remove From Vault.
7) Close the Credentials Manager.

Alternatively, you can use the Wiper utility (see attachment) to do this and clear out a bunch of other caches. (Make sure you close the Credentials Manager first as it locks the files if it is still running)

******************************************************************
MODERATOR WARNING: This is a new user and the attachment contains an exe. All executables can be potentially dangerous to your computer. As with any files you download from the internet you should only use programs from a trusted source and even then scan everything with anti-virus software. We have no reason to believe this user is anything but sincere but be advised the files included have not been tested nor recommended by the administrator or staff of w7forums, use with caution.
******************************************************************

8) Log Off or Reboot and Log back in as normal (you might want to bookmark this page or print it first!)
9) Open My Computer/Network and click on your network drive (or shared printer).
10) Enter the Username and Password and tick Remember These Credentials then Apply.
11) Open Control Panel then Credentials Manager. You should see under the Windows Credentials section your newly created account.
12) Select it and click Edit.
13) As the username replace the name to that of the server sharing the printer/drive, not the remote machine. ie. SERVER\Username instead of REMOTE\Username then Save.
14) Close Credentials Manager and Log Off again.
15) Open My Computer/Network and click on the server sharing the device. Fingers crossed it will not nag you for the username and password again!

I hope this works for you too. It's a nasty problem that has had me stumped for months. Annoying when the remote PC is your kids and they want to print out their homework and the printer is located in the other room and they constantly nag you type in the password each time!
 

Attachments

Last edited by a moderator:
Joined
Jul 27, 2015
Messages
2
Reaction score
0
hi
very new to this here.
been trying to solve the problem on the above and being not to savvy, after going to credential manager it asks for 3 boxes to be filled. first is website, i assume thats the site i am trying to download from, 2nd is username and 3rd password. now is the 2nd and 3rd the username/password for the website i am trying to access or is it the routers username and password, dont want to go messing about with the internal workings of win7 etc in case i really foul things up completeley, i have been known to in the past. the instructions seem clear enough apart from knowing what username password it really wants.
any and all help appreciated
maka
 
Joined
Apr 8, 2016
Messages
2
Reaction score
0
I had the same problem for a long while, but tonight I seem to have solved it. This is how I did it. Hope it works for you and many others. My network storage is Buffalo Linkstation LS-CHL (I will call it LS-CHL below).

Sign-in your network storage device manually as before.

Go to Credential Manager under Control Panel-User Accounts. Look for your network storage device under windows credential and open it. Then select Edit. Replece the domain name in front of your user name (LS-CHL, in my case). Save.

Log off from you Windows account and then log in again. Windows will again say it cannot connect network drive. Open Credential Manager again and you will notice that your device is not there under windows credential.

Now connect your device again manually. Then in Credential Manager click "Add a Windows Credential": enter device name (LS-CHL, in my case) as internet/network address, user name (without domain name) and password. Save.

That is it. Log off window and then log back on, your device should be connected automatically.

The sequence is important.
5 years of this symptom, typing the darn user/pwd for the NAS share, checking the useless "remember my password" box...oh so many keystrokes....but tonight I came across this fix, posted back in 2009, and yet never listed in my dozens of google searches.
Redhotorange...thank you.
 
Joined
Mar 23, 2016
Messages
6
Reaction score
2
Hello,

Whenever you are trying to map a network drive on restart of the system, there are 2 options Reconnect at Sign-in & Connect using different credentials. Make sure the Reconnect at Sign-in is always checked & after entering the credentials on login Window Check Remember my Credentials. On every restart of the system will never ask for login to your network Drives. If you have already doing this and still face issues, then you will have to modify background services. Right click on mapped drive got to properties then security, make sue the system has Full control. All check boxes should be checked.

Jammy | Sr. Tech Support.
https://www.cloudappsportal.com
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top