Windows 7 does not save network login credentials (username and password)

Joined
Apr 22, 2010
Messages
1
Reaction score
0
Hi,

I'd just like to say thanks to RedHotOrange, too.

In case this helps anyone else, I combined Keith J's suggestion of adding a generic credential also. I haven't bothered to remove one and keep the other to see which one actually works.

I also removed the DOMAIN bit form both the Windows and Generic Credential logins and after logging off and on twice during the process, they are now both displaying persistence: Enterprise, rather than Session (or what ever it said when it didn't work.

Anyway, thanks to you both for your suggestions - this will save me from not being backed up when forgetting to login to my auto-backup NAS that I thought I was already logged into!

cheers

Jonno the Fusspot
 
Joined
May 1, 2010
Messages
1
Reaction score
0
I had the same problem for a long while, but tonight I seem to have solved it. This is how I did it. Hope it works for you and many others. My network storage is Buffalo Linkstation LS-CHL (I will call it LS-CHL below).

Sign-in your network storage device manually as before.

Go to Credential Manager under Control Panel-User Accounts. Look for your network storage device under windows credential and open it. Then select Edit. Replece the domain name in front of your user name (LS-CHL, in my case). Save.

Log off from you Windows account and then log in again. Windows will again say it cannot connect network drive. Open Credential Manager again and you will notice that your device is not there under windows credential.

Now connect your device again manually. Then in Credential Manager click "Add a Windows Credential": enter device name (LS-CHL, in my case) as internet/network address, user name (without domain name) and password. Save.

That is it. Log off window and then log back on, your device should be connected automatically.

The sequence is important.
I did have a problem with following this sequence. When I go to the Network Storage Device under Windows Credentials, and click on Edit, I cant replace the Domain name because all it shows is an IP address which I can't edit.

Any ideas?

Thanks

muzz
 
Joined
Jul 20, 2010
Messages
1
Reaction score
0
Fixed in my case !!!

Same problem for wireless home setup... and here's what i did:

I previously created identical user accounts on both local and remote computers.

I started the <Credential Manager> service (was on Manual).
In "HomeGroup connections" i selected: "Use user account and password to connect to other computers" (that forced a logoff - logon sequence; the Credential Manager was still on after logon).

Now i simply mapped the drive. I've selected the "Connect using using different credentials" -> Next -> Entered the credentials and checked to be remembered.

At reboot, the drive connects successfully but Win7(6.1 Build7600) still shows a baloon about not being able to connect the network drive... but in the end it works without the need to reenter the credentials.

My first post here. Hope it helps :)
 
Joined
Aug 19, 2010
Messages
1
Reaction score
0
Welcome to the site bern!

Can you please go to Control Panel > User Accounts and Family Safety > Manage Windows Credentials

You should be able to view your saved credentials in there and check their persistence level.
Thank you, that is exactly what I needed.
 
Joined
Oct 24, 2010
Messages
1
Reaction score
0
I just signed up so I could post the simplest solution:


  1. Go to: Control Panel > User Accounts and Family Safety > Manage Windows Credentials
  2. Expand each device listed by clicking the down arrow
  3. Delete all the credentials by selecting "Remove from vault"(to make things simple)
  4. Create new credentials for each network by entering the IP address of the device you're trying to connect to. For example, most internal IP addresses start with 192.168.1.xx. The last two digits vary with each device. It could be 192.168.1.1, 192.168.1.16, etc. Enter this address in the "Internet or network address" field.
  5. Enter your username and password (don't have to enter computer name, slashes, etc)
  6. Try to connect to the network. It will now work.
  7. To double check, restart your computer. The credential will still be remembered.
I tried to write down the simplest instructions. Obviously, there is more depth to this and alternative solutions, but this one works. The issue is 1.You either did not enter your credential in the correct format or 2.You have corrupted/duplicate credentials. There is no sequence required. We usually think that if something works, the sequence must have mattered.
 
Last edited:
Joined
Nov 10, 2010
Messages
1
Reaction score
0
Humble thought

If you set up a network disc and want it to be persistent, write the following in CMD:

net use /persistent:yes

net use [Assigned Drive letter:] \\[path]\[path] to the share you want to connect.

EXAMPLE

net use /persistent:yes

net use k: \\server\my_share

All that within a domain or network group

To ease it up Create a batch file (example):

**********

if "%OS%" == "Windows_NT" goto WNT

:W95

net use * /delete /yes
net use k: \\server\my_share /yes
net use l: \\server\my_music /yes

goto common

:WNT

net use /persistent:yes

net use k: \\server\my_share
net use l: \\server\my_music

goto common

:common
exit

*********************
If your credentials are the same it should work

If the server has it's own credentials you should try with that (administrator credentials).

And you never have to run it again until you disconnect a share. :beer:


//Viper99
 
Last edited:
Joined
Feb 14, 2011
Messages
1
Reaction score
0
Windows credentials

I found a solution that worked for me. I have a Windows 7 Premium with attached printer and a laptop with windows 7 Home Premium.

On the laptop I created a credential from control panel -> credential manager.
Then from windows explorer Network->properties->Change advanced sharing settings->HomeGroup connections I selected "Use user accounts and passwords to connect to other computers"

I hope this helps.
 
Joined
Mar 31, 2011
Messages
1
Reaction score
0
This worked for me - kinda makes sense too!

1) Open the Network and sharing center
2) Select 'Choose homegroup and sharing options'
3) Choose 'Change advancxed sharing settings...'
4) Scroll down to the 'Password protected sharing' and select 'Turn on password protected sharing'
5) Press saved


It should all work now.
 
Joined
Apr 9, 2011
Messages
6
Reaction score
0
I had the same problem for a long while, but tonight I seem to have solved it. This is how I did it. Hope it works for you and many others. My network storage is Buffalo Linkstation LS-CHL (I will call it LS-CHL below).

Sign-in your network storage device manually as before.

Go to Credential Manager under Control Panel-User Accounts. Look for your network storage device under windows credential and open it. Then select Edit. Replece the domain name in front of your user name (LS-CHL, in my case). Save.

Log off from you Windows account and then log in again. Windows will again say it cannot connect network drive. Open Credential Manager again and you will notice that your device is not there under windows credential.

Now connect your device again manually. Then in Credential Manager click "Add a Windows Credential": enter device name (LS-CHL, in my case) as internet/network address, user name (without domain name) and password. Save.

That is it. Log off window and then log back on, your device should be connected automatically.

The sequence is important.
Isn't all of this a bit of a ridiculopathy? Is it only me that sees having to do something so basic as having a consistent login to a home network machine shouldn't be such a drama? No, seriously. Good solution - and good ON you, mate - but how does one contact Microsoft and tell then their "save credentials" tick box does bugger-all?
 
Joined
Apr 9, 2011
Messages
6
Reaction score
0
I just signed up so I could post the simplest solution:


  1. Go to: Control Panel > User Accounts and Family Safety > Manage Windows Credentials
  2. Expand each device listed by clicking the down arrow
  3. Delete all the credentials by selecting "Remove from vault"(to make things simple)
  4. Create new credentials for each network by entering the IP address of the device you're trying to connect to. For example, most internal IP addresses start with 192.168.1.xx. The last two digits vary with each device. It could be 192.168.1.1, 192.168.1.16, etc. Enter this address in the "Internet or network address" field.
  5. Enter your username and password (don't have to enter computer name, slashes, etc)
  6. Try to connect to the network. It will now work.
  7. To double check, restart your computer. The credential will still be remembered.
I tried to write down the simplest instructions. Obviously, there is more depth to this and alternative solutions, but this one works. The issue is 1.You either did not enter your credential in the correct format or 2.You have corrupted/duplicate credentials. There is no sequence required. We usually think that if something works, the sequence must have mattered.
Been there, done exactly that, doesn't work either. Two Windows 7 Home premium machines
with sharing enabled on both.
 
Joined
Apr 26, 2011
Messages
1
Reaction score
0
I found that if you delete your credentials under Credential Manager then you can access your mapped drives with out entering your user name and password..... HOWEVER... once you restart your computer all your credentials come back. So now my new problem is trying to permanently delete my credentials! I'm using Win7 Ultimate 64 bit Any help would be AWESOME!!!
 
Joined
Apr 9, 2011
Messages
6
Reaction score
0
I found that if you delete your credentials under Credential Manager then you can access your mapped drives with out entering your user name and password..... HOWEVER... once you restart your computer all your credentials come back. So now my new problem is trying to permanently delete my credentials! I'm using Win7 Ultimate 64 bit Any help would be AWESOME!!!
Does Microsoft monitor this thread? Or where would be a good place to discuss this with them? It seems pointless to try all these workarounds for something that is clearly a bug.

Microsoft is, at this point, protecting me from me. And not from anything else - i still have security issues.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
No, MS does not monitor this site; though occasionally some Microsoft MVPs or Techies may pop in, but don't count on it. If you expect help from them then go to the Microsoft forums.

Networks have security for a reason and you want to get around that; that's not a bug, it's a feature you don't like.
 
Joined
Apr 9, 2011
Messages
6
Reaction score
0
No, MS does not monitor this site; though occasionally some Microsoft MVPs or Techies may pop in, but don't count on it. If you expect help from them then go to the Microsoft forums.

Networks have security for a reason and you want to get around that; that's not a bug, it's a feature you don't like.
So you're saying clicking on Save Credentials and having it not save is a feature. Clever. So, the purpose of that "feature" is?
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
If you read GopherBaroque's link you will see that it is a group policy setting that is off by default. Yes I agree that having a checkbox that says save and then it doesn't save does seem stupid but it is also apparently controlled by policy settings which can be modified with the group policy editor. Group Policy Editor is only available on Professional/Ultimate/& Enterprise versions so yes it's a feature; Microsoft's favorite kind of feature, the one where you pay more to upgrade to a version that can do it. (Of course if you know what registry tweaks are needed you can make them manually w/o Group Policy Editor in any version)
 
Joined
Apr 9, 2011
Messages
6
Reaction score
0
I read GopherBaroque's link. In it he says:
"Fixing the problem requires editing the group policies. Not a difficult task, but it does entail changing some registry settings. If you are not comfortable with doing getting your hands dirty in the registry, stop now, or find someone who can do this. And be sure that you back up your registry before you start. If you screw up your registry, you might not be able to restart and use your system, so consider yourself warned."
But then, he explains how to fix the issue for Win7 Pro users using gpedit.msc. Since I'm on Win7 Home Premium, I don't have gpedit.msc, so I'll need to edit my registry by hand. The article only gave a warning that editing the registry might be dangerous: it didn't actually explain what changes to make.
Is there a resource for this information anywhere?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top