Problems waking remote machine with magic packet


C

Chuck Anderson

I have three computers on my home network.

1. Windows XP Home desktop (always able to wake with magic packet)
2. Windows 7 Pro desktop (the machine I have trouble waking)
3. Windows 7 Pro laptop (the machine that sends the magic packets)

I can send the magic packet over the LAN or WAN and it always wakes the
XP Home machine.

The Windows 7 Pro desktop is an HTPC that I want to be able to wake over
the WAN (Internet). This way I can let it sleep while I am away from
home (Windows Media Center records shows from the sleep state) and be
able to wake it up if I want to modify my recording schedule from a
remote location (using remote desktop).

I meticulously learned how to setup my Linksys E4200 router and the
Windows XP desktop network adapter so that Magic Packets always wake the
computer. (Send a magic packet on ports 7 and/or 9 and set the router
to Port Forward these to the appropriate local (static) IP address -
Linksys consumer routers do not pass broadcast packets from the Internet).

When I try to wake the Windows 7 Pro desktop (my HTPC), it usually does
not work. If I have recently pressed the sleep button on my HTPC
(Window Media Center) remote, then the packet from the laptop does
work. However, if the machine has gone to sleep on it's own - overnight
- the magic packet does not wake it. I have a simple packet sniffer
that shows me the packet is being sent to the desktop computer (when it
is awake) and I have found and complied with a checklist I found here:

http://windows7-issues.blogspot.com/2011/03/wake-on-lan-wol-for-windows-7-made-easy.html

- Enable WOL in BIOS (from boot) *** [Mine is set to S3 STR and wake up
is enabled]
- Enable WOL for your Ethernet Card (i.e. NIC)
- Install Windows Feature "Simple TCPIP services"
- Start Service "Simple TCP/IP Service" (enables ports 7 & 9)
- Open UDP for Port 7/9 in Windows Firewall
- Forward the port on your Router

Is there some deeper level of sleep it is going into - or something I
have missed in my setup? I followed every step I used to set up the
Windows XP computer, and then found the above checklist which adds even
more steps for Windows 7, but it still does not consistently work.

--
*****************************
Chuck Anderson • Boulder, CO
http://cycletourist.com
Turn Off, Tune Out, Drop In
*****************************
 
Ad

Advertisements

A

Andy Burns

Chuck said:
- Forward the port on your Router
Are you forwarding to the IP address of the HTPC, or the broadcast IP
address of the subnet the HTPC is on?
 
B

Bob I

From a comment in the link you provided.


"One thing that you DO need to do it configure your BIOS so that the
PCI-e is made live for WOL packets. You MUST have a network link light
on your ethernet even when the PC is switched off. If there is no link,
there is no way for the PC to receive the magic packet."

So check for that indicator light.
 
C

Chuck Anderson

Bob said:
From a comment in the link you provided.

"One thing that you DO need to do it configure your BIOS so that the
PCI-e is made live for WOL packets. You MUST have a network link light
on your ethernet even when the PC is switched off. If there is no
link, there is no way for the PC to receive the magic packet."

So check for that indicator light.
Thanks, Bob. You gave me something new to look at.

But .... not only is the link light on (while asleep .... I never turn
the PC off), but the activity light also blinks whenever I send the WOL
packet. Still .... ZZZZZzzzzzzzzzzzzzzzzzzzzz. Not waking up.

I looked in the BIOS for PCI-e settings and found nothing, but I
reconfirmed that Enable Wake Up and Sleep Mode S3 (STR) are enabled.
I have three computers on my home network.
1. Windows XP Home desktop (always able to wake with magic packet)
2. Windows 7 Pro desktop (the machine I have trouble waking)
3. Windows 7 Pro laptop (the machine that sends the magic packets)

I can send the magic packet over the LAN or WAN and it always wakes the
XP Home machine.

The Windows 7 Pro desktop is an HTPC that I want to be able to wake over
the WAN (Internet). This way I can let it sleep while I am away from
home (Windows Media Center records shows from the sleep state) and be
able to wake it up if I want to modify my recording schedule from a
remote location (using remote desktop).

I meticulously learned how to setup my Linksys E4200 router and the
Windows XP desktop network adapter so that Magic Packets always wake the
computer. (Send a magic packet on ports 7 and/or 9 and set the router
to Port Forward these to the appropriate local (static) IP address -
Linksys consumer routers do not pass broadcast packets from the
Internet).

When I try to wake the Windows 7 Pro desktop (my HTPC), it usually does
not work. If I have recently pressed the sleep button on my HTPC
(Window Media Center) remote, then the packet from the laptop does
work. However, if the machine has gone to sleep on it's own - overnight
- the magic packet does not wake it. I have a simple packet sniffer
that shows me the packet is being sent to the desktop computer (when it
is awake) and I have found and complied with a checklist I found here:

http://windows7-issues.blogspot.com/2011/03/wake-on-lan-wol-for-windows-7-made-easy.html



- Enable WOL in BIOS (from boot) *** [Mine is set to S3 STR and wake up
is enabled]
- Enable WOL for your Ethernet Card (i.e. NIC)
- Install Windows Feature "Simple TCPIP services"
- Start Service "Simple TCP/IP Service" (enables ports 7 & 9)
- Open UDP for Port 7/9 in Windows Firewall
- Forward the port on your Router

Is there some deeper level of sleep it is going into - or something I
have missed in my setup? I followed every step I used to set up the
Windows XP computer, and then found the above checklist which adds even
more steps for Windows 7, but it still does not consistently work.

--
*****************************
Chuck Anderson • Boulder, CO
http://cycletourist.com
Turn Off, Tune Out, Drop In
*****************************
 
Ad

Advertisements

R

Rob

Bob said:
From a comment in the link you provided.

"One thing that you DO need to do it configure your BIOS so that the
PCI-e is made live for WOL packets. You MUST have a network link light
on your ethernet even when the PC is switched off. If there is no
link, there is no way for the PC to receive the magic packet."

So check for that indicator light.
Thanks, Bob. You gave me something new to look at.

But .... not only is the link light on (while asleep .... I never turn
the PC off), but the activity light also blinks whenever I send the WOL
packet. Still .... ZZZZZzzzzzzzzzzzzzzzzzzzzz. Not waking up.

I looked in the BIOS for PCI-e settings and found nothing, but I
reconfirmed that Enable Wake Up and Sleep Mode S3 (STR) are enabled.
I have three computers on my home network.
1. Windows XP Home desktop (always able to wake with magic packet)
2. Windows 7 Pro desktop (the machine I have trouble waking)
3. Windows 7 Pro laptop (the machine that sends the magic packets)

I can send the magic packet over the LAN or WAN and it always wakes the
XP Home machine.

The Windows 7 Pro desktop is an HTPC that I want to be able to wake over
the WAN (Internet). This way I can let it sleep while I am away from
home (Windows Media Center records shows from the sleep state) and be
able to wake it up if I want to modify my recording schedule from a
remote location (using remote desktop).

I meticulously learned how to setup my Linksys E4200 router and the
Windows XP desktop network adapter so that Magic Packets always wake the
computer. (Send a magic packet on ports 7 and/or 9 and set the router
to Port Forward these to the appropriate local (static) IP address -
Linksys consumer routers do not pass broadcast packets from the
Internet).

When I try to wake the Windows 7 Pro desktop (my HTPC), it usually does
not work. If I have recently pressed the sleep button on my HTPC
(Window Media Center) remote, then the packet from the laptop does
work. However, if the machine has gone to sleep on it's own - overnight
- the magic packet does not wake it. I have a simple packet sniffer
that shows me the packet is being sent to the desktop computer (when it
is awake) and I have found and complied with a checklist I found here:

http://windows7-issues.blogspot.com/2011/03/wake-on-lan-wol-for-windows-7-made-easy.html



- Enable WOL in BIOS (from boot) *** [Mine is set to S3 STR and wake up
is enabled]
- Enable WOL for your Ethernet Card (i.e. NIC)
- Install Windows Feature "Simple TCPIP services"
- Start Service "Simple TCP/IP Service" (enables ports 7 & 9)
- Open UDP for Port 7/9 in Windows Firewall
- Forward the port on your Router

Is there some deeper level of sleep it is going into - or something I
have missed in my setup? I followed every step I used to set up the
Windows XP computer, and then found the above checklist which adds even
more steps for Windows 7, but it still does not consistently work.
What make/model motherboard is it? Some of the BIOS power setting
changes needed can be rather obscure and not at all obvious.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top