I have a strange problem with my laptop display


Joined
Sep 24, 2015
Messages
1
Reaction score
0
I have a HP Presario C700 laptop, Os Win7 home 32bit.
I was in the middle of playing an old MSDOS game on the Dosbox emulator. This is one of those newer sideways moving games that allowed jumping. It is an Apogee game called Monster Bash. The CTRL key is for jump and the ALT is the fire key. The rest is controlled by the arrow keys.
I was playing the game and the screen went black for a split second then came back up but everything, desktop, game, taskbar, the whole shooting match did a 90 degree rotate to the right. The right side of the desktop is on the bottom of the screen. And even the mouse movement is flopped over 90 degrees to the right. I tried a complete cold reboot. That didn't help. The only thing that helped ( a temporary fix) was putting the laptop in extended screen mode. My flat screen tv can also serve as an extended monitor so if I am running 2 prog's at a time, which I do sometimes in digital mode for ham radio. Or if I am working on a new game or software then I can put the instruction's on the 2nd screen. Right now with the laptop is in extended screen mode the screen is right side up. If I put the laptop back in single screen mode. The screen is again flopped over on the right side. In all the years of using Windows (starting with Win 3.1) I have never had this happen to me. Other then the screen is flopped over to the right. The laptop is in 100% working order. I am at a lose as to how it happened or how to fix it. Did I just stumble on a previously unknown design flaw in Win7 home? I can attach a screen capture if need be.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,320
Reaction score
1,584
To us your screen capture will likely appear normal. It sounds like you are simply displaying the screen portrait instead of landscape. I do this all the time at work on a widescreen monitor rotated to instead be a tall thin monitor.

Go to control panel > display > change display settings. Set the orientation to Landscape
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top