SOLVED Favorites/Links no longer work


Joined
Jun 29, 2012
Messages
79
Reaction score
1
I use a "Links Toolbar" on my Win 7 taskbar by the notification tray to access my favorite sites. The toolbar is named "Links". Here is the problem. I changed a theme last night and for some reason when I went to use one of the links what happened was clicking it opened a "Open File Security Warning". I have UAC disabled and I use Win 7 Home Prem. x64, so I don't have the ability to use GP Edit to try and kill the security warning. I thought it was something to do with a file association, but everything seems to be in order, so I just don't have a clue how to get it back to where my "Favorites" work off the toolbar in Firefox like they used to.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,317
Reaction score
1,584
By disabling UAC you make it even easier for a virus to get installed. It is quite possible that you may have downloaded a virus with the theme and that message could be part of the infection. So before we consider any other possibilities I would encourage you to reboot into safe mode and run a complete virus scan. See our Freeware DB for A/V programs if you do not currently have one installed.
 
Joined
Jun 29, 2012
Messages
79
Reaction score
1
Plenty of security on my laptop. KIS2012 and MBAM Scanner. No viruses or malware. Open File Security Warning is one of Windows Security settings. How it got back to guarding my Links/Favorites is beyond me. I have my links working now due to a System Restore, but I don't want to have to do that to fix something. I thought maybe it popped up after a SFC /scannow , but that showed no integrity violations. UAC is a pain in the rear. My philosophy concerning UAC is "if you need a pop up to warn you about installing software then you shouldn't even be installing things at all". I agree it may be appropriate for some new users to leave it till they are used to working with their machine but once you get the hang of it, Bye Bye UAC annoyance. Thanks for your suggestions. I've canned enough search engines on this subject and have yet to find a suitable answer. Good thing I do backups because this looks as though it may prove tough to solve how that setting slid in there.
 
Last edited:

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,317
Reaction score
1,584
Well, I'm glad you are sure it was a valid Windows message and not a fake popup from a virus trying to sell you junk to cure crap they created (I hope there is a special place in hell reserved for those scumbags).

I'm glad you got it working with a restore and I will mark this as solved.

I do understand what you mean about most of the recommendations telling you to use GPEDIT but one search suggested the registry settings here:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Download
"CheckExeSignatures"="no"
"RunInvalidSignatures"=dword:00000001

So maybe if this happens again see if flipping those two entries resolves your issue.
 
Joined
Jun 29, 2012
Messages
79
Reaction score
1
Well, I'm glad you are sure it was a valid Windows message and not a fake popup from a virus trying to sell you junk to cure crap they created (I hope there is a special place in hell reserved for those scumbags).

I'm glad you got it working with a restore and I will mark this as solved.

I do understand what you mean about most of the recommendations telling you to use GPEDIT but one search suggested the registry settings here:
HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Download
"CheckExeSignatures"="no"
"RunInvalidSignatures"=dword:00000001

So maybe if this happens again see if flipping those two entries resolves your issue.
Now do these registry settings kill the "Open File-Security Warning"? The reason I ask is that I didn't remember seeing these, however my eyes are still recovering from the amount of searching I did on this topic. When I started this I thought it was a simple file association that got crossed up. I hadn't seen those "security warnings on my machine for a very long time. I hope I don't ever see them again either. I use Pale Moon as my browser so I reset all the Internet and Intranet settings in Internet Options and then I got rid of Internet Explorer 9. I don't use it so if I take it out of the equation it's another thing I don't need to worry about. Just have to wait and see I guess and I'll put your last answer in my saved box for further reference. Thanks again.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,317
Reaction score
1,584
Because most of the searches recommend fixing it via GPEDIT, it is almost assuredly a registry setting because that's what GPEDIT changes but even file associations are stored in the registry so that could be part of it too.

These settings I found are definitely under IE so if you don't use IE as your browser then I don't know they would help. It seems it would be controlled by whatever executes the .LNK shortcut you are hitting. But it's all conjecture on my part, never had that issue before myself.

Still, if your registry changed, so that you noticed this issue, then you don't know what else may have changed, so it's probably best you restored it to a time when it was working.
 
Ad

Advertisements

Joined
Jun 29, 2012
Messages
79
Reaction score
1
I suppose I'll just leave it as is then and hope everything stays the way it's supposed to. Thanks my friend.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top