Cannot disconnect external drive


Joined
Jan 31, 2012
Messages
1
Reaction score
0
I just got a Dell 8300 XPS. When I try to disconnect my Seagate free-agent go external drive, I keep getting a error message that the device is still in use (even though it's not). I did not have the problem with both my other HP Win 7 computers. I have read and tried several trouble shooting methods that I have read,and stiff cannot get it fixed. Also,when I try to uninstall the driver,the box is not "highlighted" so I cannot do that function. Autoplay comes on when it is connected and I am able to open it with no problem..it's just the disconnecting that is driving me crazy!
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,354
Reaction score
1,587
You could disable write caching and then you do not need to "safely remove hardware". See HERE.

Or you might try ...

installing a program called Unlocker. Once installed open Windows Explorer and highlight the troublesome drive. Then right-click and pick Unlocker from the context menu. You will see a list of all the locks on the drive. Hit the Unlock All button. Now try to safely remove the hardware.
 
Ad

Advertisements

Joined
Feb 9, 2010
Messages
748
Reaction score
126
Just because it's not in use does not mean it's not active. Try Ctl + Alt + Del and check out the applications and process's tabs and see if there is anything associated with Seagate. If so, end the process and then try "safely remove" option.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top