SOLVED AutoPlay


Joined
Oct 8, 2011
Messages
31
Reaction score
2
AutoPlay will no longer start when I insert media. All settings in Control Panel remain the same as they were: I opt for "Ask me every time" for each media type that I use, but the AutoPlay window will not open.
 
Ad

Advertisements

Elmer BeFuddled

Resident eejit
VIP Member
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
Hi FlyNavy. See if this helps at all.

Go to the Control panel, set your view (top right corner of toolbar) to Small icons. From resulting list select "Autoplay".
In the window that opens check that the "Use Autoplay for all media and devices" box on the top left is ticked.

Autoruns also relies on the Shell Hardware Detection Service to be running and set to Automatic.
So, while in the Control Panel, open Administrative Tools and then Services and check the settings are as stated.

Open up Regedit.exe and navigate to:-
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom
and in the right hand window make sure the Autorun REG_DWORD value is set to 0x00000001 (1).

Then navigate to:-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Check for a NoDriveAutoRun entry. This is not a default registry entry so if you find one it is safe to delete. If there is an entry and it is set to 0x00000001 (1) it will disable the Autoruns.
While still in the Explorer key, check that the NoDriveTypeAutoRun REG_DWORD is set to the default 0x00000091 (145), OR, if you have a floppy drive the REG_DWORD is set to the default 0x00000095 (149).
If the NoDriveTypeAutoRun REG_DWORD is set to 0x000000FF (255) then that is definitely your problem. That setting disables AutoRun.

Nero, PowerISO, MagicISO and some other programs like VMWare add another NoDriveTypeAutoRun entry setting under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer with its REG_DWORD value is set to 0x000000FF (255). Change that setting to 0x00000091 (145). Also check for a NoDriveAutoRun entry, delete if found and all will be back to normal after you've restarted.
 
Last edited:
Ad

Advertisements

Joined
Jun 14, 2015
Messages
1
Reaction score
0
Hi FlyNavy. See if this helps at all.

Go to the Control panel, set your view (top right corner of toolbar) to Small icons. From resulting list select "Autoplay".
In the window that opens check that the "Use Autoplay for all media and devices" box on the top left is ticked.

Autoruns also relies on the Shell Hardware Detection Service to be running and set to Automatic.
So, while in the Control Panel, open Administrative Tools and then Services and check the settings are as stated.

Open up Regedit.exe and navigate to:-
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom
and in the right hand window make sure the Autorun REG_DWORD value is set to 0x00000001 (1).

Then navigate to:-HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Check for a NoDriveAutoRun entry. This is not a default registry entry so if you find one it is safe to delete. If there is an entry and it is set to 0x00000001 (1) it will disable the Autoruns.
While still in the Explorer key, check that the NoDriveTypeAutoRun REG_DWORD is set to the default 0x00000091 (145), OR, if you have a floppy drive the REG_DWORD is set to the default 0x00000095 (149).
If the NoDriveTypeAutoRun REG_DWORD is set to 0x000000FF (255) then that is definitely your problem. That setting disables AutoRun.

Nero, PowerISO, MagicISO and some other programs like VMWare add another NoDriveTypeAutoRun entry setting under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer with its REG_DWORD value is set to 0x000000FF (255). Change that setting to 0x00000091 (145). Also check for a NoDriveAutoRun entry, delete if found and all will be back to normal after you've restarted.
I am a Windows Vista Home user and happened across this "fix" after searching online for 3-4 days for a possible solution to my autoplay not functioning properly for both my CD-ROM drive & DVD-RW drive (i.e. both music & video drives). This "fix" regarding the various changes to the REGISTRY worked like a charm to resolve my issues. This should be put out to the Windows VISTA forums as well as there are many users out "there" having exactly the same problem! Thanks very much to this forum & to ELMER BEFUDDLED in particular! Kudos all around! Steve M. from AZ.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top