Autoplay does not work on DVD drive but OK with USB flash drive

Discussion in 'Windows 7 Support' started by Nick79, May 31, 2016.

  1. Nick79

    Nick79

    Joined:
    Jan 12, 2015
    Messages:
    7
    Likes Received:
    0
    Hello,

    I have built a new computer using a Hero VIII motherboard and installed Windows 7 Pro 64bit (OEM) onto a SM951 M2 drive.
    Computer spec:-
    Asus Hero VIII Motherboard,
    Intel 6700K
    16 Gbyte Ram
    Samsung SM951 M2 drive for OS
    2 off Asus DRW-24F1MT drives
    2 off Seagate 2TByte HD's
    Sandisk 256GByte SSD
    Asus GTX960 Graphics Card

    Windows was installed from one of the DVD's them using a modified installation disc created with the Asus EZInstaller and appeared to install OK. Windows installed in UEFI mode (disc partition GPT).

    Now I am starting to install software but have hit a problem when installing fron a CD or DVD - installing from a USB drive works OK.

    When I insert a DVD or a CD to install any programs the drive LED light flashes for a moment, but Autoplay does not run.

    NOTE: Autoplay does run OK when a USB drive is inserted or even when a USB 2TByte external disc drive is inserted - it just does not work when a CD or DVD is inserted in the drive.

    Now here's the strange thing....

    Selecting "Computer" from start menu or opening Disc Management while a DVD is inserted will get the drive running and autoplay will open.
    The same applies to music CD's - they will not start Media player until either "Computer" or Disc Management is opened.

    Also, perhaps even stranger, inserting a USB drive while a DVD or CD is in the drive will get the DVD drive running and autuplay will open - actually 2 instances of it open - one for the USB drive and one for the DVD drive.

    It seems the DVD drive needs a kick to get it going.

    I have checked in registry for the following entry - HKEY_CURRENT_USER\Software\Microsoft\CurrentVersion\Policies\Explorer for the entry NoDriveTypeAutoRun

    However, the folder "Explorer" does not exist in this new computer, though it does in my other computer which works and the entry is set to DWORD NoDriveTypeAutoRun Reg_DWORD 0x00000091 (145)

    I assume that as this is only required to stop autoplay then it is not necessary to have it set - is that true ?

    Another possibility is that as the drives are SATA devices could the settings in BIOS could be the cause of the problem ?

    The only setting I have adjusted in BIOS is Secure Boot which I set to "Other OS" in order to install Window 7 - it is still set to this.

    Could CSM setting have an effect on this which is still set to default of "enabled".

    Any help in resolving this would be appreciated.

    Regards,

    Nick.
     
    Nick79, May 31, 2016
    #1
    1. Advertisements

  2. Nick79

    jefboyardee

    Joined:
    Nov 27, 2013
    Messages:
    151
    Likes Received:
    10
    What does your Autoplay Control Panel look like?

    upload_2016-6-3_14-48-5.png
     

    Attached Files:

    jefboyardee, Jun 3, 2016
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.