SOLVED Autoplay done a runner.


Elmer BeFuddled

Resident eejit
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
Aaargh, My "Auto-play" has stopped. You know, the little pop-up window you get when you load a DVD/CD or use an ISO with a virtual drive. You get the option to play or search the discs files. It was there yesterday, today its gone Abo (walk-about).
Under Auto-play in the control panel all options are set at the default "choose a default", as they (to my knowledge) have always been and "Use Auto-play for all media and devices" is checked.

(This used to happen haphazardly on XP as well so I know it's not a new thing, but I can't for the life of me find the "fix" I used to use in my Tips 'n' Tweaks Library, or even remember what I called it).
 
Ad

Advertisements

Joined
Feb 9, 2010
Messages
748
Reaction score
126
Do you have the box at the top checked.
auto play.PNG

Well I spoke to soon, didn't read it carefully enough. I see that you do.
 
Joined
Feb 9, 2010
Messages
748
Reaction score
126
Check your system for bugs, registry errors, malware and spyware. Some times stuff just happens and things can get corrupted for unknown reasons that is beyond our control.
 

Elmer BeFuddled

Resident eejit
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
U fiddled wid it tilln it broke an' now ur wantin us 2 befixed it?
:aetsch: YEP!!
Check your system for bugs, registry errors, malware and spyware. Some times stuff just happens and things can get corrupted for unknown reasons that is beyond our control.
As I said, it used to happen in XP and then would cure itself :confused: without any outside frekin about by me !! Perhaps I need more :mad: patience. :mad:
 
Ad

Advertisements

Elmer BeFuddled

Resident eejit
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
Some times stuff just happens and things can get corrupted for unknown reasons that is beyond our control.

Go figure this!! :dontknow:

I've just done my 3rd boot of the day, unbeknown to me I'd left an iso file loaded in the DVDFab virtual drive (well nothings been happening since yesterday).
After I'd waved Hi to Mr. Eset man and patted Scotty Dog (WinPatrol) on the head, up popped my auto-play window!!
Noel D. Paton said:
On Microsoft Answers.
The ways of Windows are truly inscrutable, grasshopper!
:dontknow: :dontknow: :dontknow:
 
Last edited:

Elmer BeFuddled

Resident eejit
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
Finally(?) found the correct solution to this issue as it had happened again.

I wanted to make an ISO file yesterday so I installed PowerISO to do it with.
Later on my step-daughter tried to play a CD but it wouldn't "start". I told her it wouldn't play because my computer has musical integrity (not quite true!!) but I had my doubts!!

So this a.m I went for a troll through the system and registry to see what I could find.

First off, all the Autoplay settings through the Control Panel were checked, all the options were still set at the default "choose a default" setting, the "Use Auto-play for all media and devices" was still checked so there was no changes there then.

Next stop the registry. I'd recovered one of my old WinXP "Elmers Tweak-lets®" notes that helped me with this one, so I wasn't running "totally blind".
First I went to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom and made sure the Autorun REG_DWORD value was set at 0x00000001 (1), which it was.

I then went to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer and checked that the NoDriveTypeAutoRun REG_DWORD was at the default 0x00000091 (145), which, IT WASN'T!! It was in fact set to 0x000000FF (255), which is the disable ALL Autoruns setting. So I changed it back to the default setting above (note that if you have a floppy drive the default is 0x00000095 (149).

After this I just double checked that the other two (on x64) entries at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies\Explorer and HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Policies\Explorer were at the correct settings which, after changing the HKCU key entry they were.

After this I did a search for any other entries and I found one under a VMWare saved data key which had the NoDriveTypeAutoRun setting set at disabled 0x000000FF (255).
This would explain why my auto runs stopped originally. I'd had VMWare installed for a very short time last week but this key entry tells me that when it was installed it had taken over the control on how my removable media worked.

Now I can't say whether PowerISO did the same thing when I installed it yesterday as I had uninstalled it before I looked in my registry today but I have read (elsewhere) that it might/may/will do.

But now I've changed the keys back my auto-plays are running as they should do / I want them to again. In fact I've exported the default settings as a .reg file just in case it happens again.
 
Last edited:

Kalario

Aquarius
Joined
Dec 15, 2009
Messages
590
Reaction score
68
Glad to hear you have it figured out. My head was spinning reading your last post. I am ignorant when it comes to registry and BIOS!
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top