Windows 7 (6801) and iTunes 8


Joined
Nov 3, 2008
Messages
45
Reaction score
1
Hi guys!
I'm currently testing Win 7 6801 and I got this really annoying problem with iTunes 8.
I have installed it without any issue but when I open it it just doesn't appear on screen. It is present on the task manager (using around 22MB of ram) but that's it. I tryed disabling Aero and applying the compatibility options (both Vista and XP) but nothing changed. Can you help me?

Thanks!
 
Ad

Advertisements

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,473
Reaction score
632
I've had iTunes give me similar problems in Vista before and it was due to a conflicting service - it might be worth disabling any services that aren't needed and see if it loads ok?

It could just be that iTunes doesn't work with Windows 7, and might get fixed in a later version. They'd want it to work pretty quickly with the beta :)
 
Joined
Nov 3, 2008
Messages
45
Reaction score
1
can you tell my which service was?

I know that it could be just an itunes incompatibility with Win 7, but its the only program not working I have so far... this buid is incredibly stable, even if is a pre beta


maybe i can try by disabling the new taskbar (experience - NTE :D)... it shouldn't be present on this version but i enabled it
 
Last edited:

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,473
Reaction score
632
It was quite a while ago I had the problems, so I can't remember the exact one unfortunately - you could try disabling all of the non MS essential ones (just write the names down of each one you stop, so you can try re-enabling them one by one ;)).

If worst comes to worst there are some iTunes alternatives that might work (although it isn't ideal). Songbird looks pretty good : http://getsongbird.com/
 
Joined
Nov 3, 2008
Messages
45
Reaction score
1
as soon as I have time i'll try and i'll let you know, thanks!
 

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,473
Reaction score
632
as soon as I have time i'll try and i'll let you know, thanks!
Thanks, I'll update this thread if I find out anything else that might help too :)

Welcome to the site by the way :D :ciao:
 
Ad

Advertisements

Joined
Nov 3, 2008
Messages
45
Reaction score
1
=)


Ok this is weird... I opened iTunes with my iPhone connected to the PC and it opened (it told me I had put iTunes in compatibility mode with Vista) and also I got an error with the iPhone service (that wasn't loaded).
So it seems for now (just now...) that it works if I connect the phone but I can't manage it (but I don't care, I sync it with my macbook)
 

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,473
Reaction score
632
Excellent :D Sometimes computers are just strange like that ;)
 
Joined
Nov 3, 2008
Messages
45
Reaction score
1
Ok I tested around and after a reboot I don't have to connect the iPhone... it just works like a charm... all the services looks fine (I cheked if one has been disabled by the system of whatever... no clue at all).
I also disabled the backward compatibility and it all fine.
I dunno what happened... but I'm happy with that!!

Maybe windows just fixed himself (it would be my gratest dream... windows-self-reparing-feature!!)
 
Joined
Nov 27, 2008
Messages
47
Reaction score
0
I'm running this version of Windows Seven and I've just installed iTunes 8.0.2.20 and it runs without a hitch. No need for compatibility settings, it just worked straight away.

Found this forum by googling for iTunes and Windows 7 and arrived at your thread :)
 
Ad

Advertisements

Joined
Nov 3, 2008
Messages
45
Reaction score
1
yeah my itunes works like a charm now, i never figured out why... but it doesn't matter
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top