SOLVED USB suddenly STOPPED!!!


Joined
Feb 12, 2010
Messages
5
Reaction score
0
I just installed Windows 7 Ultimate on my laptop and everything worked fine. I updated Windows to Service Pack 1, and when I plugged in my USB, it stopped working!! I have 3 external drives connected to a USB hub and it stopped, please help
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,325
Reaction score
1,584
Very unlikely SP1 is at fault but you may have gotten some new drivers installed at the same time. (Make sure your Windows Update settings do not have "treat recommended updates the same as critical updates" checked if you do not want drivers installed automatically).

If you got a bad driver you can use the Control Panel > Device Manager to "roll back driver" to a previous version. If it did come from Windows Update, then unless you change the setting I mentioned above it will be reinstalled again the next time Updates run so you need to manually check for updates and then right-click and "hide update" of the offending driver.

It's also possible your hub has gone bad. Have you tried plugging your external HD directly into the USB port rather than going through the hub? If that works then your hub could be faulty or there may be hub drivers that need rolled back (I'm not familiar enough with USB devices to know if the hub, itself, would need drivers).
 
Last edited:
Ad

Advertisements

Joined
Feb 12, 2010
Messages
5
Reaction score
0
Thanks, TrainableMan for the info... I actually just updated my graphics drivers and it works now. I'm thinking of just getting a 2 or 3TB drive so I won't need the hub anymore
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top