USB Hard Drive Recognized - Not Accessible


Joined
Jan 13, 2009
Messages
6
Reaction score
0
I have a Verbatim/SmartDisk USB 2.0 Firelite external drive. The drive is recognized by the system and shows up in the Device and Printers management tool. While I can see the drive, I cannot view the data on it.

I have another external USB drive by Western Digital and it is fully recognized and accessible from Win7 RC1.

The Firelite is recognized and accessible on a WinXP system. It was working on Win7 Beta.

I am running Win7 RC1

Thoughts?
 
Last edited:
Ad

Advertisements

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,482
Reaction score
632
Does the drive show up in the drive listings in explorer view at all?

Also, do you have the latest USB drivers installed (probably using the latest chipset pack for your motherboard)? It could be a problem there as the drive works on other PCs.
 
Joined
Jan 13, 2009
Messages
6
Reaction score
0
The drive does not show up in the explorer view at all. I will look for BIOS updates and USB driver updates, although I would not think that would be it since the drive was visible on the system when the Beta release was installed.
 
Joined
Feb 26, 2009
Messages
83
Reaction score
8
Hi gregj,

Did you try rebooting your computer with the USB drive attached? this seem to work for other people with same issue with external USB drives.
 
Joined
Jan 13, 2009
Messages
6
Reaction score
0
I left the drive connected and rebooted with no joy.I have tried all the usual things with no success. Although I may have missed one or two.

What is interesting is the drive was usable with Win7 Beta - what is different now with RC that would cause the dirve to not be recognized?
 
Joined
Jan 15, 2009
Messages
8
Reaction score
0
Have you opened device manager to see if the drive is listed under the disk drive tree? Also, have you used the Disk Management utility in the Computer Management console to see if the drive needs to first be initialized on the RC1 machine? If the drive needs to first be initialized on the RC1 machine, BACKUP the data on it FIRST on another machine and then initialize the drive on the RC1 machine.
 
Ad

Advertisements

Joined
Jan 13, 2009
Messages
6
Reaction score
0
The drive does show up in device manager under disk drives. When the properties windows is opened it says that no driver is installed for the device. It would be strange to have to initialize an external USB drive for RC1 if it has been used before by other OSs and the Beta.
 
Joined
Jan 13, 2009
Messages
6
Reaction score
0
Interesting things happened as I continued to research the issue. I decided to do some experimenting with device manager.

1) I tried to update the driver, and was told it was up to date, even though it indicated no driver loaded for this device.
2) I removed all conflict errors in device manager.
3) I uninstalled the driver set that was installed the first time.

Result: The system re-installed the device and the required drivers. After re-installation, the hard drive became visible and accessible. I can now access the data sets.

Thanks to all for your suggestions.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top