turning off computer


Joined
Jan 27, 2010
Messages
43
Reaction score
2
Since installing windows 7 it takes about 5 or 6 minutes to shut down. Is that normal.
 
Ad

Advertisements

Nibiru2012

Quick Scotty, beam me up!
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
No way, mine takes about 10 seconds to shut down.

Did you do an upgrade install or a clean install?

What services are running when you shut down?
 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
I did a upgrade. And do you mean the services in the task manager? And if so, that's what I was wondering as I look at all of them and not knowing what a lot of them are. Thanks for the reply...
 
Joined
Aug 20, 2009
Messages
64
Reaction score
4
I did a upgrade. And do you mean the services in the task manager? And if so, that's what I was wondering as I look at all of them and not knowing what a lot of them are. Thanks for the reply...
If the swap or paging file is being overwritten you may be able to keep this from happening by opening the registry and locating the key{ \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management}, then change the value of ClearPageFile at Shutdown to a 0. A value of 1 will overwrite the file, which i would actually recommend for security. Also, you must also restart your computer.
to open the registry:start,run,and type{regedit}.
 

davehc

Microsoft MVP
Joined
Jul 20, 2009
Messages
1,958
Reaction score
502
If you are happy with editing the registry, do this: (You must do all three)

Navigate to HKEY_CURRENT_USER\Control PanelDesktop\
Highlight the WaitToKillAppTimeout value.
Set it to 1000.
Now highlight the HungAppTimeout value
Set it to 1000′ also.

And for all users
Navigate to to ‘HKEY_USERS\.DEFAULT\Control
Panel\Desktop
Highlight the WaitToKillAppTimeout value.
Set it to 1000.
Now highlight the HungAppTimeout value.
Set it to 1000.


And to kill any lingering services:

Navigate to
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Contro l\
Highlight the value WaitToKillServiceTimeout
Change this value to 1000.

You can try lower values, but this hack has been in use since early Vista, and the recommended values have been found as the best compromise.
 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
O.K. Thanks, But before I try this how do I save my registry first? Then another question - how does this different from King64 's reply?
 
Ad

Advertisements

Joined
Aug 20, 2009
Messages
64
Reaction score
4
O.K. Thanks, But before I try this how do I save my registry first? Then another question - how does this different from King64 's reply?
Just open your registry and click on FILE,and save your registry to any place you want on your pc,if you want to put hem back again,for somme reason,is just locate the registrybackup and double click on it and you got hem back again.

on registry is the second name after you click on FILE.
 

Nibiru2012

Quick Scotty, beam me up!
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
Socko, we have been rude. Welcome to the Windows 7 Forum website! :ciao:

I see that you said you upgraded on the install. A LOT of people going the "upgrade install" path have been experiencing problems.

I would highly recommend to you that you do a clean or custom install, as Windows calls it. Your system will run much faster, be more responsive and not have near the problems you have now.

I know its a pain in the butt to do it, but you will definitely notice a difference. Nearly all the people who come here with problems and issues did the "upgrade install" method.

Be sure you have all the proper drivers beforehand and you're good to go.

Also if you post your system's specs in your Control Panel area, it will help.
 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
Thank you everybody. Looks like it is fixed. I typed regedit in the START window area and hit enter. The computer shut down for some reason. Re-started it and now it shuts down like it is suppose to. Takes about 10 seconds now. I don't know what happened. I'm saving all the info you guys gave me in case I have trouble later. And by the way the next time I will post my systems specs. But how do I do that? Other than typing all of them.
 

Nibiru2012

Quick Scotty, beam me up!
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
Go to the "USER CP" tab at the upper left of the page, the go to the "Edit System Specifications" section. There you can post what you have like the motherboard, CPU, RAM, hard drives, monitor, etc.
 
Ad

Advertisements

Nibiru2012

Quick Scotty, beam me up!
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
It's a feature here on the forum website so you can add an avatar, user info, etc.

Short for User Control Panel

It's third from the left on the image below:

 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
O.K. thanks, got it. Understood. I was looking in the computer control panel. Dumb me.
 

Nibiru2012

Quick Scotty, beam me up!
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
Don't worry about, you'll see that there are a lot of options in the User CP you can input.
 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
I don't know if I should open another thread or not. I'm back to my problem of not shuting down right. Anyway I went to file to save the registry, but there is no save there. Second , when I get to the directions from davehc in the registry I follow direction untill I get to the last "highlight the Wait to Kill APP timeout value. That phrase is not there. Also not there in the other two Wait to Kill app, Hung App. So I'm stuck on what to do?
 
Joined
Jan 27, 2010
Messages
43
Reaction score
2
I have no idea what I'm doing . I just went to the CP and listed my systems specs.. Then hit papeclip. Said nothing there. I give up. Thanks
 
Ad

Advertisements

Joined
Aug 20, 2009
Messages
64
Reaction score
4
I have no idea what I'm doing . I just went to the CP and listed my systems specs.. Then hit papeclip. Said nothing there. I give up. Thanks
Socko,you can do what i said on my first post,don't be afraid,and you solve your prroblem for sure,
to make an registrybackup,go to:START,RUN,and type,regedit,and hit enter,the registrybox will open,then on the left side up,clic on FILE,and open the options small box,clic then on EXPORT,and save the registrybackup to documents for example,
after you backed hem up clic on:HKEY_LOCAL_MACHINE then SYSTEM then CURRENTCONTROLSET then CONTROL then SESSIONMANAGER then clic on MEMORYMANAGEMENT and on your right side,you'll see an key called CLEARPAGEFILEATSHUTDOWN,right clic on it and open an small box,clic on CHANGE and you'll see the key value HEXADECIMAL,if there you have 1, just change it to 0 and clic OK,close your registry and restart your pc,that's all.

Note:when you go to find the value key on registry,clic always on the small arrow to open until you find "memorymanagement" right here you clic on it to see the key you looking for on your right side "clearpagefileatshutdown" got it?
Good luck!!
 
Last edited:

yodap

No longer shovelling
Joined
Mar 30, 2009
Messages
1,430
Reaction score
340
Socko, do you have "run" showing in the start menu? I don't think it's there by default.

You can type run in the search box or pin it to the start menu through properties.
 
Ad

Advertisements

Joined
Aug 20, 2009
Messages
64
Reaction score
4
Socko, do you have "run" showing in the start menu? I don't think it's there by default.

You can type run in the search box or pin it to the start menu through properties.
By default is always there!!!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top