SOLVED Some programs won't run after reinstalling Windows 7

Oct 16, 2019
Reaction score
I'm at my wits end with this one, hopefully someone can help me out.

I was running 'Band-in-a-Box' Version 10 on Windows 7 Home Premium with Service Pack 1, 64-bit. One day out of the blue, the program would not load beyond welcome screen, and in the Task Manager, it did not appear in Applications but did appear under Processes.

I ran check for viruses and malware, system clean. I decided to run Disk Defrag, but this crashed system and the computer would not boot.

I removed hard drive and rescued documents and programs,then reinstalled Windows 7 to the original format.

I attempted to reinstall the software, but received the error message:

'The version of this file is not compatible with the version of Windows you're running. Check your computers system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.'

I have tried running all available compatibility modes, DOS emulators, virtual machines, software updates and all sorts of solutions that I found online to run 16-bit or 32-bit programs (not sure which it is) on a 64-bit system, but nothing has worked.

I don't think there's any solution out there that I haven't tried, but does anyone think they might have a solution?

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question