Networking: Win7 keeps asking for password when there isn't one!


Joined
Jan 12, 2011
Messages
11
Reaction score
2
Hi have 2 Windows 7 Premium computers - one is 64-bit and the other is 32-bit.

Last night, I was transferring files over the network for hours with no problems at all, from the 32 to the 64 bit. No passwords were involved because there were no password set up (and there are none - I checked).

Today, however, the 64-bit computer wants a password for the 32-bit machine... yet there is none!

Any reason for this? Thanks in advance, folks!
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,586
I'm not an expert on networking but I do notice in this ARTICLE it says in Clifford's addendum that you can turn off password protection, maybe that will fix your issue?
 

Kougar

OCing one chip at a time
VIP Member
Joined
May 11, 2009
Messages
588
Reaction score
116
Have you tried leaving the field blank and just hitting enter? XP used to require that sometimes...
 
Joined
Jul 23, 2011
Messages
6
Reaction score
0
hey try setting a password for each pc ( make it easy,so u dont forget), then got to your network sharing panel and adjust your sharing option . i think you need a password in order for it to work.Also windows 7 has a default password for homegroup, should be in the same panel.
 
Last edited:

davehc

VIP Member
Joined
Jul 20, 2009
Messages
1,958
Reaction score
502
Rob's idea might work.
But, on the 32Bit machine, type, in the Start or run box
Control Userpasswords2
Untick the square "Users must enter ..etc"
Apply
 
Joined
Jan 12, 2011
Messages
11
Reaction score
2
Excellent answer...

but that box was already un-checked. And as I said before, the problem began out of nowhere - no changes had been made. But THANK YOU MUCH!!
 
Ad

Advertisements

davehc

VIP Member
Joined
Jul 20, 2009
Messages
1,958
Reaction score
502
OK. Then do this
Open the Control panel (Icon view)
Choose Properties (this opens Control Panel\Network and Internet\Network and Sharing Center)
Open Network and Sharing Center
Click "Change advanced sharing settings" (Over on the left) , and select and expand your home group6.
Look at next to last setting - Password protected sharing
Turn off password protected sharing - Save chnges.
 
Joined
Jan 12, 2011
Messages
11
Reaction score
2
Did that but now instead of asking for a password....

...it's saying the drive is inaccessible and talks baout my not having permission, etc.

It *can* access everything under my username on Drive C.. but none of the folders under the root of Drive C.

Thanks - if you have any other tips, i will use them!
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,586
Windows 7 does not like you to share the root directory. I suspect because it has so many system folders under it and even some system files sitting within the root itself.

It is a better idea to create a Subfolder like C:\Shared and share that. Much safer.

If you insist on sharing the root then read HERE
 
Joined
Jan 12, 2011
Messages
11
Reaction score
2
BINGO!!! This is the solution that worked (thank you!!!!)

Windows 7 does not like you to share the root directory. I suspect because it has so many system folders under it and even some system files sitting within the root itself.

It is a better idea to create a Subfolder like C:\Shared and share that. Much safer.

If you insist on sharing the root then read HERE
-----------------------------------
OK, this is the problem with Windows 7: I had ownership of the drive on the local machine (default), but that is not enough. I had to give "everyone" ownership of the drive for other computers to access it. That means logging-in through the network from another machine to the Win7 computer, you have ownership as "everyone" and therefore, permission to access the drive.

So, here is what I did. Right click on the hardrive from windows explorer. Go to properties. Click on Security. Click edit. Add "everyone" to the group and assign the permissions you want. Then go to sharing and share the drive as you would normally. The root of the drive will now be accessible over the network.

I understand it now, but this is very poorly explained in every document I read. I spent hour researching this and can't understand why MS has made it so diffucult to share a drive over a network. Totally absurd.

Hope this helps out others trying to do the same thing. In a small home network, It is very common/necessary to share multiple drives at the c:\ root.
 
Last edited by a moderator:

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,586
I'm not sure why you posted the info from the link I gave?
 
Ad

Advertisements

Joined
Jan 12, 2011
Messages
11
Reaction score
2
Thanks - here's why

I'm not sure why you posted the info from the link I gave?
Because I super appreciated it and felt others would find it a lot easier if I re-posted it. In fact, the solution was one of many posted on that page.

Thanks to you, it's working like a charm!
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,586
I still discourage sharing the root of your OS drive but I'm glad it worked for you. I will mark this thread as solved.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top