SOLVED My Sony Vaio Laptop is not connecting to Virgin Superhub


Joined
Oct 31, 2010
Messages
15
Reaction score
0
Good afternoon.
My Sony Vaio Laptop, model number PCG-61211M, is running Windows 7 Home Premium (64 bit). Until last week it connected to my Virgin wireless network without any problems. This week we upgraded to a Virgin Superhub. The Laptop reports (in Control Centre / Network Settings) that it is connected to this new network, and that the signal is strong, but if you try to access the internet an error message is returned stating that it cannot load that page because it is not connected to the internet. (My desktop computer and I-phone are both connecting to the Superhub without any problems.) Re-booting the laptop and/or the Superhub does not solve the problem.

From browsing on the web I can see that other users have had similar issues, and the most oft cited fix is to download an updated driver for the wireless function. The laptop is running an Atheros AR9285 Wireless Network Adaptor, driver date 5/10/2009, driver version 8.0.0.238. I have tried to access an updated version of this driver via the Sony support page, but it does not recognize my laptop model number (this is the model number printed on the underside of the laptop, so it ought to be recognized).

My questions are:
1. Does the Sony Vaio PCG-61211M go by another model number? If so, where can I find it?
2. Leaving aside 1, from where can I download a reliable updated version of Atheros AR9285?
3. Given that my laptop has no internet access at present (but my desktop computer does), is it possible to download the updated driver on to a data stick plugged into my desktop computer (ie, without installing it on to the desktop computer, as that seems to be working fine), and then transfer the data stick to the laptop and install the updated driver from there manually?

I would be most grateful for any advice you can offer.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
Atheros.cz

Download the driver win7-v10.0.0.285-whql.zip with your desktop PC and extract the 8 files from the zip file to a flash drive. Then put the flash drive in the Vaio and look at the files in Windows Explorer. Right-Mouse click on file netathrx.inf and choose "install" from the context menu.

NOTE: Do not try to install netathr.inf because that is for 32-bit.
 
Ad

Advertisements

Joined
Oct 31, 2010
Messages
15
Reaction score
0
Hello TM - thank you for replying; you sorted out my Samsung SCX-4100 a few years back, and it's good to see that you are on the (new) case!

OK, so I downloaded the driver you stipulated (from www.atheros.cz), and extracted the 8 files on to the flash drive. I then put the drive into the Vaio and examined the files. I right-clicked on netathrx and this showed me a menu of options starting with 1. open, 2. install, 3. print (I assume this is what you mean by the context menu). I chose install and it returned this error message: "The Inf file selected does not support this method of installation.'

So, I'm stuck. Any thoughts?
 
Joined
Oct 31, 2010
Messages
15
Reaction score
0
PS - I have just discovered that what I thought was the laptop model number (PCG-61211M) is just the chassis model number. The laptop is actually model number VPCEA1S1E.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
I didn't use the laptop version at all, I used the driver "Atheros AR9285" so that shouldn't be a problem.

As for it not installing that way ...
Try going to Control Panel > Device Manager
And double-click on the Atheros AR9285 Wireless Network Adapter
In the new window choose the Driver tab and click the Update Driver button
Choose Browse my computer
Point to the flash drive netathrx.inf file and let us know if it installs that way
 
Joined
Oct 31, 2010
Messages
15
Reaction score
0
Thanks.

I followed these instructions, which all worked fine up to 'point to the flash drive netathrx.inf file'. I could only point to the folder in which this file was located (along with the other 7 Atheros files). I think it installed correctly anyway however. The Device Manager shows that I have updated the wireless network adapter to 'Qualcomm Atheros AR9285' dated 14/2/2014, version 10.0.0.285. If I click on driver details I see "C:\windows\system32\drivers\athrx.sys" and "c:\windows\system32\drivers\vwifibus.sys".

I then rebooted the laptop, checked that the laptop was reporting that it was connected to the Virginsuperhub wirelessly (as before, it was), and that the updated adapter was still showing as installed (it was) and then tried to access the web through Chrome. Same error message as before, which is pasted below:

"This webpage is not available

The server at www.amazon.co.uk can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address. This error is most often caused by having no connection to the Internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.

Check your DNS settings

Contact your network administrator if you're not sure what this means.

Try disabling network prediction

Go to the Chrome menu > Settings > Show advanced settings... and deselect "Predict network actions to improve page load performance." If this does not resolve the issue, we recommend selecting this option again for improved performance.

Allow Chrome to access the network in your firewall or antivirus settings.

If it is already listed as a program allowed to access the network, try removing it from the list and adding it again.

Error code: DNS_PROBE_FINISHED_BAD_CONFIG"

Not sure what to try next...
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
OK, so your driver updated, which is good, but it probably was not the problem in the first place.

Apparently you are trying to use Chrome as your browser. Could you try IE or Firefox and see if the results are the same?

Did you install anti-virus software on this computer that comes with a firewall? A firewall can block internet access, for example my A/V will say "internet spades is trying to access the internet ... Allow or Deny" and there is also a check box to "always allow this application". If your firewall blocked Chrome from accessing the internet then another browser may work and if that's the case then we need to adjust your firewall settings.

On the other hand, it may be that your computer does not have a proper DNS server set up. If your computer is set for DHCP then it should get the DNS address from the router. The DNS servers are normally provided by your ISP (and a back-up) or you can set it to a public DNS server such as google (8.8.8.8 and 8.8.4.4). But you can specify them in Network Settings on the computer and that may be set incorrectly and be causing the problem. So follow the information HERE and see if your computer is set to obtain the address automatically or if DNS IP addresses are set on your computer, and if they are, verify they are correct.
 
Joined
Oct 31, 2010
Messages
15
Reaction score
0
PROBLEM SOLVED

Hello there,

Before I saw your latest message I was browsing in the Virgin Community boards and came across folk who had experienced the same problem. The following solution was posted by 'paralegal-eagle' and seemed to have worked for several people, so I tried it (substituting the Atheros driver for the Intel one mentioned below of course), and the laptop is now connecting wirelessly to the Superhub. (I didn't see 'dinotify.exe' in task manager / processes so I just skipped that step.)

No idea WHY this worked when simply updating the driver did not, but I'm glad it's all sorted out. Thank you for helping me along the way.


"1) Go to the Intel Driver Update Utility for Wireless and download the necessary updated driver file

2) Open Network and Sharing Centre from Control Panel, Network and Internet

3) Click on Change Adapter Settings in the left hand column

4) Open your wireless network from the list and click on Properties (the one with the shield before the word)

5) Click the Configure button in the dialogue box that has now opened.

6) In the dialogue box that has now opened click onto the Driver tab and click Uninstall.

7) Once the driver has uninstalled, restart the laptop

8) Once restarted, open the Task Manager (control, alt + delete) and click onto Processes.

9) End the process called dinotify.exe - this will stop the wireless card attempting to re-install the device driver which would prevent the intel driver installation process.

10) Install the downloaded driver from whatever file you saved it in on your laptop.

11) Hey presto - your wireless should now be working. Repeat steps 1 - 5 without the uninstall bit to check the driver version number - this should be a more recent version number (i.e. a larger number)."
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,302
Reaction score
1,583
So it was the driver but it had to be installed in a special way ... Weird!

But I am glad you got it worked out and also thank you for sharing the solution you found back here.
 
Ad

Advertisements

Joined
Oct 31, 2010
Messages
15
Reaction score
0
No problem. I have a related issue which I will post on a separate thread.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top