logging in automatically after logout


T

Tom Hall

System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.

Tom
 
Ad

Advertisements

S

Stan Brown

System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.
"Doctor, doctor, it hurts when I do this."
"Well then, don't."

Seriously, what would you expect the system to do when you log out.
Logging out says "close this user session." It's hard to see how
that should mean "and immediately open a new one for the same user."

Though this _is_ the system where you use the Start button to shut
down.
 
T

Tom Hall

Seriously, what would you expect the system to do when you log out.
Logging out says "close this user session." It's hard to see how
that should mean "and immediately open a new one for the same user."

Though this _is_ the system where you use the Start button to shut
down.
Sometimes there are missing icons in the system tray. Logging off and on
again nearly always fixes things.

Tom
 
W

WayPoint

System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.

Tom
Tom

Not sure if this is helpful - but for what it's worth:

(1)
http://channel9.msdn.com/Blogs/coolstuff/Tip-Auto-Login-Your-Windows-7-User-Account

(2)

Click the Start Button and search for a Control Panel setting named
"Notification Area Icons".

Perhaps there is a setting in there that may sort the issue you have.

Good luck
Graham
 
B

BobbyM

System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.
When you log off, are there any other administrators or users that are
shown on the log in screen?
 
V

VanguardLH

Tom said:
System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.
Do a restart of Windows instead of logging out. On the restart, you're
logged in automatically as you stated.

I'm not sure you'll see much improvement in boot-to-ready time by
hibernating and restarting from that. On fast hosts, the difference
between booting up normally and resuming from hibernation isn't enough
for me to bother hibernating. I suppose that depends more on how many
startup items you have and how long those take to load. You could use a
shortcut to the shutdown.exe program included in Windows, as in:

shutdown.exe /r

You could double-click on the shortcut instead of having to navigate the
Start menu. I don't know if the /h switch for hibernation can be used
with the /r switch to restart to reduce restart time. There will be
time during the shutdown to save the memory image into a disk file so it
really depends on what you load as startup items as to whether or not a
clean boot would be slower or not than saving memory into the
hiberfil.sys file and then resuming from hibernation. Obviously using
the program to [hibernate] and restart would still require you to
configure Windows to automatically login using your account EVERY time.
 
V

VanguardLH

Tom said:
Sometimes there are missing icons in the system tray. Logging off and on
again nearly always fixes things.
Until the process that manages its tray icon again forgets to perform a
refresh of its state, and then you'll be logging off and on again.
Report the problem to the author of the software that doesn't properly
manage its own tray icon.
 
S

Stan Brown

Sometimes there are missing icons in the system tray. Logging off and on
again nearly always fixes things.
Or you could just restart Explorer, which is equally effective and
much faster.

1. In Task Manager, on the Processes tab, find explorer.exe and click
End process.

2. Tremble not at the popped-up warning, but click End Process on the
confirming prompt.

3. Click File » New Task, type explorer and hit the Enter key or
click OK.

This also resets the taskbar if auto-hide is malfunctioning.

(BTW, Ctrl-Shift-Esc brings up Task Manager, and on some systems it
does so without the intermediate prompts that Ctrl-Alt-Del puts you
through.)
 
S

Stan Brown

Until the process that manages its tray icon again forgets to perform a
refresh of its state, and then you'll be logging off and on again.
Report the problem to the author of the software that doesn't properly
manage its own tray icon.
Are you sure the application is at fault, and not Windows? I often
see an icon for Action Center, though I have it set to "notifications
only".
 
Z

Zaphod Beeblebrox

On Sun, 08 Sep 2013 17:48:04 -0600, "Tom Hall" <aria1946
@gmail.com.invalid> wrote in article
System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.
I'll leave others to suggest other means to achieve your desired
result, but here is an answer to your OP. Caveat: I have not tried this
under Windows 7 but it does (did) work under Windows XP:

Run regedit and navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
\Winlogon

Change the value for the ForceAutoLogon key to 1. If ForceAutoLogon
does not exist, create a new String Value (type REG_SZ) registry key
with the name ForceAutoLogon, and then set its value to 1.

HTH
 
T

Tom Hall

Are you sure the application is at fault, and not Windows? I often
see an icon for Action Center, though I have it set to "notifications
only".
I'm pretty sure it's a Windows issue, which is why I'm trying to make the
logoff-logon process as streamlined as possible.

Tom
 
T

Tom Hall

(BTW, Ctrl-Shift-Esc brings up Task Manager, and on some systems it
does so without the intermediate prompts that Ctrl-Alt-Del puts you
through.)
Yes, this works for me too.

Tom
 
T

Tom Hall

shutdown.exe /r
I have a Logoff shortcut on my desktop.
hiberfil.sys file and then resuming from hibernation. Obviously using
the program to [hibernate] and restart would still require you to
configure Windows to automatically login using your account EVERY time.
This is precisely what I want to do - unconditionally bypass the login
screen.

Tom
 
T

Tom Hall

Run regedit and navigate to:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion
\Winlogon

Change the value for the ForceAutoLogon key to 1. If ForceAutoLogon
does not exist, create a new String Value (type REG_SZ) registry key
with the name ForceAutoLogon, and then set its value to 1.

HTH
Thanks for the tip. I did this but I'm still presented with the logon
screen after logging off.

Tom
 
Z

Zaphod Beeblebrox

On Mon, 09 Sep 2013 10:52:35 -0600, "Tom Hall" <aria1946
@gmail.com.invalid> wrote in article
Thanks for the tip. I did this but I'm still presented with the logon
screen after logging off.

Tom
Presumably you have done the "Not sure if this requires it but since it
is Windows I'll reboot just in case"? Several articles indicate it
should work.

If you've already rebooted and it still isn't working, I've now noticed
that there is disagreement among the articles as to whether it should
be a REG_SZ String Value or a DWORD (32-Bit) value. You might try
deleting it and re-creating the key as a DWORD value and see how that
works.
 
G

Gene E. Bloch

System here is Windows 7 Home Premium 64-bit.

I am trying to get the system to log me back in automatically after I log
out. I am logged in automatically when I start the system, but if I log
out, I'm presented with my username and a password prompt.

I've checked several registry settings, but nothing seems to work. Could
there be some kind of group/system policy that is overriding this feature?
I don't have group policy editor.

Tom
Frankly, I suspect that it's by design.

But it's not necessarily how I would have designed it, since AFAICT it
adds no security to a system where logon from a cold start is automatic.

Maybe the suggested work-arounds to getting the system tray icons back
are good enough for your purposes. Or maybe not - they too are a lot of
work, IMO.
 
Ad

Advertisements

T

Tom Hall

Presumably you have done the "Not sure if this requires it but since it
is Windows I'll reboot just in case"? Several articles indicate it
should work.
Restarting often results in a different set of missing icons. Sometimes
only 2 or 3 are missing, sometimes as many as 6. For some reason, logging
off and on again restores all icons nearly 100% of the time.
If you've already rebooted and it still isn't working, I've now noticed
that there is disagreement among the articles as to whether it should
be a REG_SZ String Value or a DWORD (32-Bit) value. You might try
deleting it and re-creating the key as a DWORD value and see how that
works.
Yup. Did that too. No joy.

Tom
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top