Legacy TV Tuner prevents SLEEP mode


Joined
Sep 11, 2012
Messages
3
Reaction score
0
hey, i have a similar problem with my pc to THIS thread except its when i use my tv tuner. I have a drive Legacy kernel caller keeping my pc awake. How do i do an override so it ignores it? ive tried powercfg -requestsoverride DRIVER "Legacy Kernel Caller" System

MOD NOTE:Added reference to old thread and moved this to a new one
 
Last edited by a moderator:
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,319
Reaction score
1,584
Is the system telling you that is what keeps it awake?

Maybe your system doesn't support sleep. What is your computer make/model?

Have you checked for a BIOS update, as sometimes those are required to allow sleep on older hardware?
 
Joined
Sep 11, 2012
Messages
3
Reaction score
0
My laptop goes to sleep perfectly before I switch on media centre and load the live tv section up. From that moment my powercfg requests tells me it's a legacy kernel caller that is keeping my laptop awake. I'm
Pretty certain it's the tv card that is the problem
But their support and help is terrible. Not sure what to do. I've even tried overriding powercfg override Driver legacy kernel caller system but my
Laptop ignores that. The laptop is an Asus running 64bit windows 7. Only 5 months old
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,319
Reaction score
1,584
When Media Center is open you are likely watching TV or a movie and so you don't touch the keyboard or mouse much. Would you really want the screen to shut down while you are watching a program?

Now once you shut down Media Center will it sleep then or is it stuck until next reboot once media center/your TV tuner are used?

Are you using the latest drivers for your TV tuner card?
 
Last edited:
Joined
Jun 13, 2011
Messages
199
Reaction score
10
have you looked in power option to see if any of the option are changed, i set mine to never sleep.
 

Core

all ball, no chain
Moderator
Joined
Feb 13, 2009
Messages
1,173
Reaction score
271
The override command you're using is case-sensitive, so make sure you spell it correctly:
Powercfg -requestsoverride Driver "Legacy Kernel Caller" System
 
Joined
Nov 24, 2010
Messages
6
Reaction score
1
Hi, well after two years I did an email about my old thread. Anyway, powercfg worked for me on that machine however, I have two Win7 64bit machines that will notgo back to sleep on their own after doing a WHS backup. Different issue I suppose as they will sleep if I set for a time period. In any case, keep playing with powercfg, I just had to find the right combination. I believe I had to use the quotes but most postings from powercfg users I found doing seraches made no mention of the quotes. Sorry I can't be of more help.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,319
Reaction score
1,584
Off topic for Runza, this is just for Dogfather:

It was nice of you to return and answer the OPs question. As for the Windows Home Server backup and it not sleeping after. Make sure your computer has the latest BIOS as it could be an ACPI issue. It may also be an open file across the LAN. See an Answer HERE about letting it sleep even with open shares.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top