How to uninstall Direct X? Or how to fix Bioshock.

Aug 27, 2011
Reaction score

I am trying to run Bioshock on a new Windows 7 64bit install. Following advice on the 2K Games forums and elsewhere I installed the "DirectX End-User Runtime Web Installer" that installed Direct X 9.0C on my system as part of the installation. ( Now I can run the game but have tried every bit of advice about fixing my random crashes and none have worked.

I'm a bit suspicious about Direct X 9.0 as I don't even think Bioshock should be running Direct X 9 as it's a Direct X 10 game. I made a dump of Bioshock.exe last time it failed and used WinDbg to read it which produced a bunch of warnings about Overlaps between Direct X 10 and Direct X 9:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\XXXX\Desktop\Bioshock.DMP]
User Mini Dump File with Full Memory: Only application data is available

Symbol search path is: *** Invalid ***
* Symbol loading may be unreliable without a symbol search path.           *
* Use .symfix to have the debugger choose a symbol path.                   *
* After setting your symbol path, use .reload to refresh symbol locations. *
Executable search path is: 
Windows 7 Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: SingleUserTS
Machine Name:
Debug session time: Sat Aug 27 11:37:22.000 2011 (UTC + 1:00)
System Uptime: 0 days 2:25:43.951
Process Uptime: 0 days 0:11:24.000
.....................................WARNING: d3dx9_33 overlaps d3d9
........WARNING: dinput8 overlaps msvcr80
..........WARNING: winspool overlaps version
WARNING: winspool overlaps wow64cpu
............WARNING: dxgi overlaps uxtheme
..WARNING: d3d10 overlaps d3dx9_33
......WARNING: propsys overlaps MMDevAPI
.......WARNING: AudioSes overlaps d3d8thk
...WARNING: msg711 overlaps IPHLPAPI
.....WARNING: d3dx10_33 overlaps dxgi
.WARNING: D3DCompiler_33 overlaps AcXtrnal

*** ERROR: Symbol file could not be found.  Defaulted to export symbols for ntdll.dll - 
*** WARNING: symbols timestamp is wrong 0x4ce7ca38 0x4e212273 for wow64cpu.dll
00000000`74b32e09 c3              ret
0:000> .symfix +c:\symcache
0:000> g
       ^ No runnable debuggees error in 'g'
And now I find I can't get rid of it.

Does anyone have any advice?



^ The World's First ^
May 10, 2010
Reaction score
- Revert to a Restore Point prior to install. (type Restore Point in Start Search box).
- Or reinstall W7

Those are the official options. You can also search the internet for some suggestions about deleting the DirectX folders from the registry but how effective or how risky that is I do not know.


Apr 2, 2009
Reaction score
The DirectX 9 redistributable is required, even for DX10 and DX11 games. All versions of DX are backwards compatible, so having the correct files to perform non-DX10 or non-DX11 effects is essential.

You're barking up the wrong tree by trying to remove or reinstall DirectX. It can't be done, anyhow.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads