How to disable Windows 7 Enterprise 64-bit security/login screens?


Joined
Sep 14, 2012
Messages
5
Reaction score
0
I have a corporate Lenovo T420s laptop that is imaged with Windows 7 Enterprise 64-bit edition. I want use this laptop as a test laptop. On boot up, I am prompted to press the CTRL-ALT-DEL keys and then enter my Username and Password. How can I disable both of these prompts and boot up directly to Windows?
 
Ad

Advertisements

Joined
Sep 14, 2012
Messages
5
Reaction score
0
I logged into the network with the Administrators account and disabled Ctrl-Alt-Del for Logon. Then, rebooted but after I went to the start menu search box and entered in netplwiz, there wasn't a box to uncheck "Users must enter a user name and password to use this computer." See attachment. I was still prompted to enter a username and password to login to the network.
 

Attachments

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,347
Reaction score
1,587
What I could find seems to suggest that it is disabled for you because your computer is likely on a Domain so the only way to automatically logon is with a registry setting and for it to work you must in Vista/W7 be sure to specify the Domain in "DefaultDomainName".

See mydigitallife (for W7 use the choices that say "Vista").


If you are NOT on a Domain then let me know that and I will see what else I can find.
 
Last edited:
Joined
Sep 14, 2012
Messages
5
Reaction score
0
I am on a domain. Followed the steps you provided, rebooted and now I am prompted to enter a password for user .\
When I click on Switch User, there is an icon for user .\ and Other user.
 
Joined
Sep 14, 2012
Messages
5
Reaction score
0
My mistake. My previous post is what I received after trying the steps below. I will re-visit your post later today.

Click the start button and in the search box type “regedit” and press <enter>.

Next expand the registry tree to match this path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

You will want to modify or create each of these registry entries:

DefaultUserName

DefaultPassword

DefaultDomainName

AutoAdminLogon

If any of the above keys are missing, create a new String Value (REG_SZ). Fill them out with the appropriate values. Set AutoAdminLogon to 1 to enable the auto logon, and if AutoLogonCount exists, delete it.

You can quit the registry editor now and restart your computer. You should find that it logs in automatically when it starts up.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,347
Reaction score
1,587
Another one mentioned this stuff. Maybe try that ForceAutoLogon entry?

HKLM\SOFTWARE\Microsoft\Windows NT\Current Config\WinLogon
AutoAdminlogon 1
DefaultDomainName *****
DefaultUserName ******
DefaultPassword ******
ForceAutoLogon 1

Afraid that's all I know; you might have to run some searches on "windows 7 auto logon in domain". Nothing more I can add.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top