SOLVED USB won't work


Joined
Apr 20, 2015
Messages
14
Reaction score
0
Hi
Funny thing at the moment is that my external drives won't show up in the computer window. But my USB sticks work perfectly each time I plug one in.

I've tested the hard drives on my laptop running Windows 10 and they show up as normal without any problems.

So why don't they work on my desktop computer.

Another strange thing is that I've had the disk management window open and the external drives have all appeared there one after another as I've plugged them in, yet none show up in the Computer window.

The reason for asking the question is I have the complete series of Star Trek Voyager (yes, a Treki at heart) on the desktop computer and wanted to transfer them to an external hard drive for safe keeping and ended up putting them on a 64GB SSD USB stick.

Any body have the same problem and like to tell me how to rectify it.

Thanks a lot.
Michael(centurian)
 
Ad

Advertisements

Joined
Dec 23, 2015
Messages
12
Reaction score
3
Try this, open an elevated (admin) command prompt
Type these commands. Press Enter after each one

Diskpart
Automount enable
Exit
Exit

See if that works.
 
Joined
Apr 20, 2015
Messages
14
Reaction score
0
Hello TrustMe
Thanks for the work around, it works a treat. Still can't get the drive to show up on the desktop like it did before this problem showed up, but I'm now able to plug in an external drive with all my films on and look through it on Computer.

Thanks again.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,584
Another strange thing is that I've had the disk management window open and the external drives have all appeared there one after another as I've plugged them in, yet none show up in the Computer window.
Could you take a screenshot of Diskmgmt when the drive(s) attached? It may be as simple as right-clicking and assigning the partition a drive letter.
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,584
That definitely shows as an assigned drive. Based on that the drive should show up in Windows Explorer as your G: drive.

What do you mean it doesn't show up on your desktop? Are you referring to the Autorun/Autoplay screen that can popup when you plug in a USB drive? If so then check the Control Panel settings > Autoplay.
 
Ad

Advertisements

Joined
Apr 20, 2015
Messages
14
Reaction score
0
Yes
That's the one.
It showed up as you inserted the drive and opened to show what was in it as well. My password file was there in a mili second and I could scan down it and find what I was looking for straight away, but now I have to click on Computer to see all that.

Its not that much of a pain but I liked it the way it was before, you get used to these thing's.

Playing with the Autorun/Autoplay window didn't improve the situation.
 

Attachments

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,342
Reaction score
1,584
If you are comfortable in the registry then run regedit & go to key ...
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Is there "NoDriveTypeAutoRun" & if so note the entry & its' value & then delete it. Reboot & then plug in your external drive and see if it works as desired. (Try your thumb drive & make sure it still works the same as always).

The other possibility is that it may be related to protections they put in place because some nasty viruses were using autorun to spread via external devices; if so then that functionality is gone.
 
  • Like
Reactions: Ian
Ad

Advertisements

Joined
Apr 20, 2015
Messages
14
Reaction score
0
Hello TrainableMan
You certainly know your stuff, because the registrary thing worked a treat.

Many thanks for that.

Michael.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top