Unable to connect to WPA2-PSK on Windows 7 Ultimate 64 bit


Joined
Nov 29, 2014
Messages
2
Reaction score
0
Good afternoon everyone,

Could you please be so kind and help me solve this issue I'm experiencing right now?

At this moment, I'm unable to connect to WPA2-PSK wireless.
When trying to connect, I receive "Windows was unable to connect to ..." error.
No issue on WEP connections.

System: Laptop Lenovo IdeaPad Y5070 cu procesor Intel® Core™ i7-4710HQ 2.50GHz, Haswell™, 15,6" Full HD, 8GB, 1TB, nVidia GeForce GTX 860M 4GB.

The Ethernet cards installed on machine are:

Realtek RTL8168-8111 Family PCI-E Gigabit
Intel Dual Band Wireless-AC 7260
(also Bluetooth Intel Wireless 4.0 + HS Adapter)

Operating system used: Windows 7 Ultimate x64
Same issue on another identical laptop.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,321
Reaction score
1,584
WEP is more likely to connect because it is less secure, WPA2-PSK requires you have the router wpa2-psk password.

You didn't tell use the make/model of the router so this assumes your router even supports wpa2-psk in the first place, relatively old ones might not.
 
Joined
Nov 29, 2014
Messages
2
Reaction score
0
I have no antivirus installed on laptop.
The wirless (router) is not the issue. I managed to connect severel times with other laptops (older ones), with a smartphone and one tablet - all connected just fine on WPA2-PSK.

Don't know what is the issue. Maybe the drivers or not as good as they should be for Intel® Dual Band Wireless-AC 7260 802.11ac, Dual Band, 2x2 Wi-Fi + Bluetooth 4.0* device.

I recently tryed Windows 7 Profesional x64. Same issue. Password is being asked but still receiving error "WIndows was unable to connect to.."
No issue on WEP.

Please see attached print screens of wireless settings on router and on laptop device.
 

Attachments

Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,321
Reaction score
1,584
Well there is a newer driver from the 19th of this month you might try, see Intel
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top