SP1 "slipstreaming" faliure KB976933-LangsCab0.cab extraction


Joined
Nov 9, 2011
Messages
4
Reaction score
1
hi all!
i am new to this forum, i specifically selected to join here for resolving an issue regarding offline slipstreaming of SP!. Though MS doesnot officially provide slipstreaming of SP1, i know we can use RT7lite or DISM to do offline slipstreaming.

My daughter recently bought an ACER laptop which came loaded with minimal LINUX; and the dealer sold a windows 7 original DVD. Unfortunately it is pre-sp1. windows 7.

i thought i will use RT7lite to slipstream SP1 and also add latest post-sp1 updates before loading the Windows. ( i have my desktop running on windows 7 64bit with sp1 updated). RT7lite stops showing that Service pack not integrated properly.

So i thought i will check to see manually if i can slipstream; i understand the procedure from net and this forum; i ran the sp1.exe to obtain the cab files. i extracted all files in the bigger cab (using expand command) in a flat folder. i also expanded the nestedmpp cab; i can see the update.ses and .mum files which require modification for offline (not installed).

But the problem comes with Lang0.cab to lang6.cab files. Lang6.cab file is smaller and extracts quickly and without error. When i try to extract lang0.cab file (using winrar, 7-zip or uniextract) get the error message that blah~blah~blah (each time i get different file name!) file cannot be created. I then thought the sp1 file i downloaded is corrupt so i redownloaded another time (fc gives that both files are bit perfect matching!) and with this again the error comes.

so i decided to look into this exactly which file is failing. Wonder of wonder, testing archive gives no error; When i open another folder and extract the files, it extracts smoothly. To be precise,winrar shows that KB976933-LangsCab0.cab has 11862 files expanding to 232 mb; after extracting about 8900 files it starts giving errors. NOW if i open another folder and extract the rest of files, it extracts them without error.

if i try to copy the files from the new folderr to the original folder i get a windows error " cannot copy "blah blah file"; The directory or file cannot be created. So i understand it is something to do with the unusally long names (winemb-errorreporting~31bf3856ad364e35~x86~fr-fr~6.1.7601.17514.cat) with ~ characters. if i rename the file as Test.cat it copies smoothly!

with this background, my questions now:
1) i think probably the issue is do with the unique shortname business as renaming is working;
2) i tried to change the temporary file location but it doesnot help as windows file ultitlity comes into play to copy the file from Rar$temp folder to the lang0folder.
3) i dont know if others ever had this problem and i am surprised ; i used my laptop on xp and my daughters with minixp to extract and failed;
4) as i am using en-us lang pack i am sure i neednot copy other language files as i am slipstreaming for my personal use and i dont require french, finnish or swedish or chinese strings! how i can filter them from the cab while extracting without manually scanning these file names.
5) there is no automatic renaming option to the extractor; even if it does, then the cabfilelist (which windows shall be using to use the cat file) will be all wrong.
6) i believe online updating will work as only en-us files will be extracted and updated;
7) is there a limit on number of files (based on unique short file names?) i thought the number is well beyond 30000 and not the 8892 files!
8) ASIDE: i also find two archives:: integrationcomponents.iso and precompact.iso in the extracted folder; what are they for and what should i do with them

=============
thanks for your patience reading the long post; hope i get some useful answers.

regards
neelakantan
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,341
Reaction score
1,584
Here is a tutorial on how to slipstream SP1.

But there is no need, just download the W7 w/ SP1 ISO with links here and then use your legit key.
 
Ad

Advertisements

Joined
Nov 9, 2011
Messages
4
Reaction score
1
@trainableman and @ davehc

aa) thanks for your reply; yes i have already located these integrated win7 isos;
bb) but the issue is the failure of extractor (expand command or win7 or 7-zip) to completely extract the files in the cab; the error is the traditional error 0x00070052 which is (or ought be) irrelvant for an ntfs drive;
cc) is there a problem if you have FAT32 as the first primary partition (where i have dos, iso images etc); to be precise, i use smartbootmanager to boot into dos, xp or win7; when i getinto dos i invoke the first partition and the dos invokes grub4dos where i have the option to go to xp (ntldr), win7 (bootmgr) or linux (pclos2010)

i need to know where is the issue and if others had similar experience when using the expand kb~~~~lang0.cab -F d:\lang0cab

regards
neelakantan
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top