Print Spooler Not Automatically Starting on Boot


Joined
Mar 28, 2011
Messages
4
Reaction score
0
Every time I boot my Win7 64 bit computer, I have to manually start my Print Spooler. I've tried it all - Services: Print Spooler-Start Automatically-Apply . . . Ran MS troubleshooter for the printer. Sprint spooler starts, but reverts back to Manual on every boot. All drivers for my HP Laserjet 1200 are current. All MS system updates are current. HELP!
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,341
Reaction score
1,584
Check your MSCONFIG.EXE and see if the service is unchecked there. If your computer is using Selective Startup.from MSCONFIG.EXE and that is not checked then it shouldn't start.

Also it may be dependent on another service called RPC. Make sure "Remote Procedure Call (RPC)" service is set to automatic in your services (SERVICES.MSC) and again that this one is not unchecked in msconfig.exe.
 
Joined
Mar 28, 2011
Messages
4
Reaction score
0
Thanks for the reply. I checked your suggestions and they were not the problem. PRC is on "Automatic" but my print spooler service reverts to "Manual" on every boot even after I restart that service and choose automatic.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,341
Reaction score
1,584
You might try Mr Fixit, available here (in step 2).

If that doesn't help, you might also try this although I can tell you I print just fine on my little USB connected printer without enabling LPD Print service or LPR Port Monitor but I suppose it's worth a shot.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top