New Creative Audigy Drivers for Windows 7


spearace

VIP Member
Joined
Oct 22, 2008
Messages
211
Reaction score
15
daniel_k has released some new Audigy drivers (also for Audigy 2/4) which work on Windows 7 and includes some of the mixer software from the driver CDs.

http://forums.creative.com/creativelabs/board/message?board.id=soundblaster&thread.id=139702

Supports any model of the following Sound Blaster cards (based on Emu10kx DSP):

- Audigy
- Audigy 2
- Audigy 2 ZS
- Audigy 4

Host-based Audigy SE/LS/Value and Live! 24-bit cards are not supported.

Operating systems supported: 32-bit and 64-bit editions of Windows 7 / Vista SP1 & SP2 / XP SP3

Included in the pack:

- Audigy series driver 2.18.0010.17
- ALchemy 1.25.10
- Audio Console 1.31.10
- DDL License Activation 1.00.04 (*)
- Dolby Digital Live Pack 3.00.01 (*)
- EAX Console 3.00.56 (Windows XP only)
- Graphic Equalizer 2.00.65
- MediaSource DVD-Audio Player 2.00.78
- SoundFont Bank Manager 3.21.00
- Speaker Settings 2.00.60
- Surround Mixer 4.00.63 (Windows XP only)

(*) Purchase and activation required, more info at http://buy.soundblaster.com.




Fixes and improvements:

- Updates all InstallShield setup scripts to support Windows 7.
- Fixes installation INI to properly install applications depending on the detected OS.
- Removes COM workaround for Equalizer, fixed by Creative.
- Adds workaround to a memory corruption issue preventing Equalizer from starting on Windows 7/Vista.
- Updates shared modules, responsiveness on certain applications is improved.
- Enables CMSS2 and Stereo Surround.
- Fixes 32-bit ASIO not working on Windows 7 x64.
- Fixes Encoder not available on Windows 7 x64 (related to fix above).
- Modifies default format on Windows 7 / Vista to 24-bit, 48kHz.
- Properly adds support for 64-bit OpenAL and 64-bit ASIO.
- Sets default speaker setting to 5.1 to properly reset configs to their defaults during install (fixes Bass and Treble leves not set to 50% on Windows 7 / Vista).
 
Joined
May 6, 2009
Messages
3
Reaction score
0
sound blaster Live

Hi Daniel,
I have Dell dimension 8100 PC with PCI Sound Blaster Live card installed. It is very old card came with the PC. Window 7 does not recognize it. I downloaded Audigy_SupportPack_2_0.exe from your site. During installation, it says device is not installed and program terminates. This is not an Audigy type card. It was working in XP3. Any help will be appreciated. Thanks.
Skadakia
 
Ad

Advertisements

Ian

Administrator
Joined
Oct 17, 2008
Messages
3,472
Reaction score
632
Does Windows Seven not detect your sound card automatically?

If not, try this link:

http://support.creative.com/Products/product_list.aspx?catID=1&CatName=Sound+Blaster

Then click on "live" and look under the archived products section. It should list some of the soundcards made for Dell in there, and allow you to download the Vista drivers (which should work in Windows 7).

Otherwise, you can enter your Dell service tag here and download the Vista drivers from Dell support:

http://support.euro.dell.com/support/downloads/index.aspx?c=uk&l=en&s=gen
 
Joined
May 6, 2009
Messages
3
Reaction score
0
Sound blaster Live! Value card Driver for Window 7

Hi Daniel,
Thanks, I tried loading driver from Dell and a patch from Creative sites. The card installed is Sound Blaster Live! 512V (Value). I could not find VISTA driver.
Window 7 does not detect the card. So when I tried to install driver it stops.
Thanks,
 
Joined
May 6, 2009
Messages
3
Reaction score
0
Creative SB Live! Value (WDM)

Hi Daniel,
I found the SB Live! CD that came with the PC. I installed using this CD and everything now works fine. The driver name is "Creative SB Live Value (WDM)". Thanks for your help.
skadakia
 
Joined
May 14, 2009
Messages
6
Reaction score
0
Does Windows Seven not detect your sound card automatically?

If not, try this link:

http://support.creative.com/Products/product_list.aspx?catID=1&CatName=Sound+Blaster

Then click on "live" and look under the archived products section. It should list some of the soundcards made for Dell in there, and allow you to download the Vista drivers (which should work in Windows 7).

Otherwise, you can enter your Dell service tag here and download the Vista drivers from Dell support:

http://support.euro.dell.com/support/downloads/index.aspx?c=uk&l=en&s=gen

i tried that but did not work. i have a Soundblaster 5.1 and went through the wizard on W7-no luck.

http://www.filecluster.com/downloads/kX-Project-Audio-Driver.html

this driver seems to work with S Blaster 5.1 Live. :)
 
Joined
May 14, 2009
Messages
1
Reaction score
0
Greetings Daniel,

I have an ASUS-A8N-SLI motherboard. It is not recognizing the Creative X-Fi XtremeGamer soundcard. I downloaded the Windows 7 64 bit Beta driver. When tried to install the beta driver,it terminates stating that the product is not installed.

As an observance during the boot process i see a couple of IRQ's repeated. Say IRQ 5 (multiple entrees). BIOS - IRQ is set to Auto.

Appreciate help.

thanks
/.rgk
 
Ad

Advertisements

Joined
Nov 7, 2009
Messages
1
Reaction score
0
Uninstalling.....

Hi... my name is zahid... iam from pakistan... i installed ur drivers...it works fine... i installed advanced eax driver patch on it... then my centre speaker does not work.... i reinstall ur new drivers again and again but now my centre speaker is not working...i have audigy 2....
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top