DPI Font Size rescaling is not working properly in Windows7


Joined
Sep 1, 2010
Messages
3
Reaction score
0
I have an application working fine with windows xp with resolution as 1024 X 728
where as the same application UI is not appearing properly in windows 7
The right and bottem borders of the form is not appearing.
Applilcation is Windows application.
We are using one main panel in the form, which is entirely visible in Windows xp
where as the same panel's right and bottom edges are not appearing properly
there a white band is coming at the right and bottom edges.

If I adjust the resolution to 1728 X 1024 then the bottom border
is appering but in the place of right border the same white band is coming.
 
Ad

Advertisements

Nibiru2012

Quick Scotty, beam me up!
VIP Member
Joined
Oct 27, 2009
Messages
4,955
Reaction score
1,302
Firefox says the link is not to be trusted:

This Connection is Untrusted

You have asked Firefox to connect securely to www.senditglobal.com, but we can't confirm that your connection is secure.

Normally, when you try to connect securely, sites will present trusted identification to prove that you are going to the right place. However, this site's identity can't be verified.

What Should I Do?

If you usually connect to this site without problems, this error could mean that someone is trying to impersonate the site, and you shouldn't continue.
WTH? Is this something new in the FF 3.6.9?
 

yodap

No longer shovelling
VIP Member
Joined
Mar 30, 2009
Messages
1,430
Reaction score
340
Here are the screen shots.
I got nothing. What program is running. It looks like he's running 7 in some kind of basic theme, but that should not matter.
 

Attachments

yodap

No longer shovelling
VIP Member
Joined
Mar 30, 2009
Messages
1,430
Reaction score
340
WTH? Is this something new in the FF 3.6.9?
Nibs, I got the same deal on 3.6.3 on my XP machine.
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,341
Reaction score
1,584
I cannot be absolutely sure but it appears to me that W7 allotted space for scroll bars for the embedded window where XP didn't. My best guess would be that window application controls (scroll boxes, menus, etc) are treated slightly different in W7.

Are you the developer of this application or the end-user? If you are the developer, what compiler is used to create this application, example Powerbuilder? Have you tried recompiling this application using W7 run-time libraries? if you are an end-user, can you contact the developer and see if they have a newer version tested out on W7?

Basically I believe this comes down to subtle differences in application control handling in W7 and would likely need to be resolved by the developer.

One idea would be to disable AERO and see if it has any effect on the W7 display of this application, though I don't believe it will. It could very well come down to making the embedded window 1 or 2 pixels smaller and recompiling so W7 does not calculate the need to show a scrollbar.
 
Last edited:

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top