SOLVED Why can't I get USB devices to wake my computer from sleep?


Joined
Jan 13, 2010
Messages
4
Reaction score
0
I want my USB keyboard to wake up my Windows 7 computer. I went into Device Manager, found the USB root hub, and under the 'power management' tab, the "Allow this device to wake the computer" is greyed out and unselectable.

So how do I allow my USB device to wake up my computer?
 
Ad

Advertisements

davehc

VIP Member
Joined
Jul 20, 2009
Messages
1,958
Reaction score
502
I have not tried through that route. I think you must go to each usb device in turn and apply the option (mouse: keyboard etc)
 
Joined
Jan 13, 2010
Messages
4
Reaction score
0
There are no power management options for the specific mouse/keyboard drivers.
 

davehc

VIP Member
Joined
Jul 20, 2009
Messages
1,958
Reaction score
502
In Device Manager, as I am sure you found, there are several USB Root Hubs,
You may be able to identify which hub the mouse and keyboard are connected to from the Power tab; then you only need to enable that one hub, and can let the PC turn off the others. But have you tried any of the others?
 
Joined
Jan 13, 2010
Messages
4
Reaction score
0
I have been able to identify which HUB my devices are plugged into, but, like I said in the OP:

the "Allow this device to wake the computer" is greyed out and unselectable.
 

Kougar

OCing one chip at a time
VIP Member
Joined
May 11, 2009
Messages
588
Reaction score
116
There are a few things to check. Biggest one is to go to your Device Manager and look under "Keyboards". Right-click the keyboard itself and select the power management tab. It will give you an option here to allow the device to wake the system.

If this setting is ALSO grayed out, then make sure the sleep/suspend settings in the BIOS are enabled. Most often these can be found in the Power Management Setup area. There is also a setting here to allow the keyboard to wake up the PC, this must be enabled as well.

There are a few more things it could be but the above two should do it for ya.
 
Ad

Advertisements

Ad

Advertisements

Joined
Jul 23, 2015
Messages
1
Reaction score
0
Hello Derbal213,
Could you share your BIOS changes to fix your issue? I had same issue with usb device (connect to front usb port). Its option "Allow this device to wake the computer" is greyed out and unselectable. The only option i can check/uncheck is "Allow the computer to turn off this device to save power", but it is not what i need

In summary, my purpose is have one usb device (will show under Human Interface Device list of device manager). Browse properties of this HID device, it shows it connect to hub #7, so i went to "Universial Serial Bus controller", select the 7th USB Root Hub and see the device there, but in Power management tab, option "Allow this device to wake the computer" is grey out

Could you advise this?
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top