SOLVED Updates causing automatic shut down


Joined
Sep 18, 2010
Messages
104
Reaction score
3
Like the title states, I just had another one of these 10 minutes ago, it included this: Security Update for Windows 7 (KB979687) etc etc.
I have updates set to automatic, and ocassionly I am not asked for permission to allow a restart, I just lose everything I have and the restart begins by shutting down. This has not caused me any problems, but if I am in the middle of important work which I do not get a chance to save it will. Is there some way to stop this happening?
 
Ad

Advertisements

Joined
Jul 17, 2010
Messages
196
Reaction score
70
If you are annoyed by frequent automatic updates that interrupt you, many of which require that you restart your system, the solution is to change your updates settings.

Control Panel
Windows Update
Change Settings link
click arrow in dropdown menu and change to: "Check for updates but let me choose whether to download and install them"

With this setting (which I use), you will still check for updates, but have the option to wait to download them later, when you are not in the middle of doing something else that you may end up losing during the restart process. Another important benefit to this setting is that you can look over the updates first, before you download any of them, then decide which ones you want and which ones you do not need and can hide from future update notices.
 
Last edited:
Joined
Sep 18, 2010
Messages
104
Reaction score
3
Hi Etalmar, I did that thanks a lot for the feedback :)
I thought my computer would always ask my permission to restart but obviously not. This should solve the problem.
 
Joined
Jul 17, 2010
Messages
196
Reaction score
70
You're welcome, Jimmy. Glad I could help. BTW .. welcome to the forum!
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,353
Reaction score
1,587
Actually that will prevent it from downloading at all without your permission - it doesn't actually force it to ask for permission to restart once you have allowed the update and it has finally completed that much.

There is a registry setting to prevent update-forced restarts. This allows you to leave auto-update on w/o the fear of a forced restart after it completes...
If you have W7 Pro or Ult you can run the group policy editor (gpedit.msc).

  1. On the left find "Computer Configuration > Administrative Templates > Windows Components > Windows Update".
  2. On the right, double-click "No auto-restart with logged on users for scheduled automatic updates installations" and, in the properties window, "Enable" it. Click OK.
If you have starter or home you need to run the registry editor (regedit.exe) and make the changes manually. (As with all registry changes this should be done by someone very comfortable with messing with W7 innards and it is recommended you back up your registry first - I am not responsible if you FUBAR your system ... and even if you blame me, good luck finding me :p )

  1. Locate "HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows".
  2. Highlight "Windows" on the left and then right-click, create New ... Key called "WindowsUpdate" if it does not exist (no quotes, no space, capitalized as shown)
  3. Now Highlight WindowsUpdate and right-click, create New ... Key called "AU" (no quotes, capital letters)
  4. Highlight AU and on the right side, right-click and create New ... DWORD "NoAutoRebootWithLoggedOnUsers" (No quotes, no spaces, Caps as shown) with a value of 1.
 
Last edited:
Joined
Jul 17, 2010
Messages
196
Reaction score
70
Jimmy, regardless of whether you decide to make the registry setting change that TrainableMan suggested or not, I would still recommend that you leave the windows update setting as I mentioned in my first post, since you should get yourself into the habit of being more selective as to which updates you download, instead of just automatically accepting whatever Micro$oft tells you that you need, as more often than not some of those updates will cause issues for your OS.
 
Last edited:
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,353
Reaction score
1,587
You'll get no disagreement from me; I don't allow auto-update on mine either, in fact I disable it on every piece of software I install. I was just saying you could.

I would suggest both options. Control the install and control the restart.
 

catilley1092

Win 7/Linux Mint Lover
Joined
Nov 13, 2009
Messages
3,507
Reaction score
563
I no longer run auto updates myself. The last thing I want when I'm using my computer is to have to restart to install updates. Most of the time, it would warn me, but a couple of times it didn't, so I trashed auto updating.

I found that the best time to do updating is prior to taking a shower in the morning. That way, by the time I get out, all that I have to do is hit "restart", and get dressed. Works perfectly for me, every time.

Cat
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,353
Reaction score
1,587
Well Cat, the Group Policy Editor change I mentioned would eliminate your "not wanting to have to restart" excuse but there are good reasons for controlling when updates use your bandwidth and even times you may not want some "critical" updates installed. Hello MS, there is nothing critical about silverlight or a new IE version!
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top