SOLVED How can I get rid 'Task Host Window' message at shutdown?


Joined
Aug 5, 2013
Messages
19
Reaction score
2
Every time I want to turn off my laptop, windows will definitely give the message says that ;-

" The following program are still running > Task Host Window"

I have found some solution to solve this with : -
Start --> All Programmes --> Accessories --> system tools --> Task Scheduler --> Task Scheduler bookcase --> Microsoft --> Windows --> RAC Right click RacTask and disable it.

That's right, this way solve the problem but it's only for a while, which means I have to perform this method every time I want to turn off my laptop to get rid the 'Task Host Window' message & this is really tiring....

I even try method form Microsoft Support > (There is a delay when you shut down, restart, or log off a computer that is running Windows 7 or Windows Server 2008 R2), but went I try to install it, it says that 'The update is not applicable to your computer'.

So may I know how can I get rid 'Task Host Window' message at shutdown permanently?
By the way I'm using a Windows 7 (64bit) SP1
 
Last edited:
Ad

Advertisements

Joined
Aug 5, 2013
Messages
19
Reaction score
2
See if you can install Hotfix KB975777 and then let us know if it resolves the problem.
First of all , Thank you for replying to my problem. Previously I already told that 'Hotfix KB975777' didnt work for me...
I even try method form Microsoft Support > (There is a delay when you shut down, restart, or log off a computer that is running Windows 7 or Windows Server 2008 R2), but went I try to install it, it says that 'The update is not applicable to your computer'.
So far , Most of the ways that I find on the internet, such as: -

"Press Windows key+R. Type regedit and pres enter. If UAC prompts, click Yes. Go to HKEY_LOCAL_MACHINE->expand System->expand CurrentControlSet->click Control (do not exapnd this). When you click (or select) Control, you can see WaitToKillServiceTimeout. Double click it to edit the value. Set the value to 500 or less than that. Click Ok and close the Registry Editor. Now restart the PC. If the issue persists, restart again and check."

or

" Go to the Task Scheduler (may be found under Administrative Tools from the Programs Menu)
Find the entry Task Scheduler Library/Microsoft/Windows/RAC and delete the task in the right pane."


it's only solve the problem for a while or I have to perform this method every time I want to turn off my laptop to get rid the 'Task Host Window' message......

I even try to adjust my startup on 'System Configuration', and it didn't solve my problem....


I heard, some people said this problem caused by an corruption installation on a third party software or anti virus, So right now I'm checking my system restore & uninstall one by one all my software to detect with of them that cause the Task Host Window error .....
I Think this the only hope for me & I really hope i can solve it because almost all solution for this problem that i search on the internet doesnt work for me...

[UPDATE 12/10]
I notice that the '1 program still needs to close > Task Host Manager' problem occur only after 2 hour I'm using my laptop, which mean If I'm using my laptop less than 2 hour than shut it down, the error will not came ( shutdown as usual,no error), So every time I uninstall any program ( Right now, I'm doing this is to detect with of them that cause the Task Host Window error, my system restore before this error happen already replace by other system restore, so i can revert back ), I have to wait for almost about 2 hour to shut down my laptop & this is tiring...... I also notice that the message error constantly change , sometimes is says '1 program still needs to close > Task Host Manager' & sometimes it just says ' Waiting for background program to close' ( without mention about Task host manager).....

Hopefully, there somebody would help me find solution for this problem... I'm tired to wait for 2 hour everytime I uninstall any program just to detect with of them that cause the Task Host Window error .....
 
Last edited:
Joined
Aug 5, 2013
Messages
19
Reaction score
2
Thank to God, After spend 24 hour in front of my laptop & try/making some experiment on all method in the internet, at last I managed to get a solution for this problem.

There are three (MAIN) ways to fix this problem, you just have to try one of these three ways, see which one is able to solve your problem ( or you can just try all of them ): - ; -

1st Step > Modify Regedit
- Open 'regedit' ( type on the start menu search bar ), then go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
- In the right pane, right click on WaitToKillServiceTimeout, and click on 'Modify' & change the value data to '2000', then click 'OK'.
- Next go to (still on the regedit windows) HKEY_CURRENT_USER\Control Panel\Desktop HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
- In the right pane, right click on ( any where on that pane) > choose 'New' > ' String Value' > name it as 'WaitToKillServiceTimeout' & Set Value data to 2000, then click 'OK' ( right click on WaitToKillServiceTimeout, and click on 'Modify').

2nd Step > Perform Clean Boot
- Click Start Menu button > type msconfig.exe in the Start Search box, and then press Enter to start the System Configuration utility.
(Make sure you Log on by using an account that has administrator rights*)

- On the General tab, click the Selective startup option, and then untick/uncheck the Load startup box. (The Use Original Boot.ini check box is unavailable.)

- On the Services tab, click to select the Hide all Microsoft services check box, and then click Disable all.

- Then restart you laptop, after reboot back (after launch the startup) then try to shut down see if this method solve your problem

3rd Step > Scan your computer with ' Malwarebytes Anti-Malware' software
- On the Scanner tab, choose Perform full scan & choose your all your hard drive ( in my case i split my hard drive in to two, where it call C: Drive & F: Drive , so I have to choose boths. If you have only want hard drive where normaly it call as C: drive, just choose that one.)
(Time taken( to finish) depends on how many programs are available in your computer, to more you have the long time it take)

- After finish scanning > click on Show Results button > tick/check all the thing in the Vendor section > click on Remove Selected button > click Yes button > click Exit button

- Then try to shut down see if this method solve your problem

*4th Step > Unplug any USB except for keyboard, mouse, monitor, power
- In my case, I unplug my earphone

*5th Step > Turn off all anti virus that running on your notification area/taskbar


* ( 4th & 5th STEP IS JUST AN OPTIONAL METHOD INCASE THE MESSAGE STILL APPEAR AFTER YOU DID 3 STEP THAT I LISTED BEFORE)

I hope this method help everybody out there who can perform the 'Hotfix KB975777'.
 
Last edited:
Joined
Aug 2, 2015
Messages
1
Reaction score
0
I simply unplugged my HP desktop for a few minutes and it stopped. Before you get caught up in all the scans, consider the apps that follow your activity trying to catch up with your bandwidth. Works like a charm.
 
Joined
May 19, 2009
Messages
26
Reaction score
1
I had the same problem. Tried everything - no results.

I recently upgraded RAM and problem was solved. I guess some process was in pagefile and system needed more time to restore it before regular shutdown.

So, try upgrading RAM... I upgraded from 4 to 8 GB on my laptop.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top