"Hide extensions of known file types" won't stay unchecked


N

nukid

"Hide extensions of known file types" won't stay unchecked on a fresh OEM
install of Windows 7. It did stay unchecked with previous versions of
Windoze (XP, Vista). Is there some trick, registry hack, or something
that's needed to prevent Windows 7 from "helpfully" resetting this (and
"Hide system files", etc.) to their defaults on every reboot?
 
Ad

Advertisements

G

Gene E. Bloch

"Hide extensions of known file types" won't stay unchecked on a fresh OEM
install of Windows 7. It did stay unchecked with previous versions of
Windoze (XP, Vista). Is there some trick, registry hack, or something
that's needed to prevent Windows 7 from "helpfully" resetting this (and
"Hide system files", etc.) to their defaults on every reboot?
Since it never gets unchecked on my Windows 7 computer, I suspect the
"doze" is in your setup. Sorry that I have no further clues.
 
B

Bob I

"Hide extensions of known file types" won't stay unchecked on a fresh OEM
install of Windows 7. It did stay unchecked with previous versions of
Windoze (XP, Vista). Is there some trick, registry hack, or something
that's needed to prevent Windows 7 from "helpfully" resetting this (and
"Hide system files", etc.) to their defaults on every reboot?
Look at the settings in the privacy software you are running that
prevents the settings from being saved to registry.
 
D

Dave-UK

nukid said:
"Hide extensions of known file types" won't stay unchecked on a fresh OEM
install of Windows 7. It did stay unchecked with previous versions of
Windoze (XP, Vista). Is there some trick, registry hack, or something
that's needed to prevent Windows 7 from "helpfully" resetting this (and
"Hide system files", etc.) to their defaults on every reboot?
These values [0 or 1] hide extensions of known file types and system files:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"HideFileExt" should be zero to show file extensions.
"ShowSuperHidden" should be 1 to show system files.
 
J

JJ

These values [0 or 1] hide extensions of known file types and system files:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
"HideFileExt" should be zero to show file extensions.
"ShowSuperHidden" should be 1 to show system files.
Might want to enable auditing for that subkey to see which processes modify
its values.
 
N

nukid

Look at the settings in the privacy software you are running that
prevents the settings from being saved to registry.
I'm not running any privacy software. This happened from the outset, with
a fresh OEM install and nothing else installed yet, turning that setting
off while logged in to the administrator account.

And I checked the registry keys someone else named. After I change the
settings, the registry *does* reflect the changes ... until the next
reboot. Something is reapplying the Windows factory default values for
those registry keys at boot time, *not* preventing the keys from being
changed to begin with. (Indeed, I don't know if it would work for even
the rest of one session if the keys weren't being changed at all.)
 
M

Mike Barnes

Gene E. Bloch said:
Since it never gets unchecked on my Windows 7 computer, I suspect the
"doze" is in your setup. Sorry that I have no further clues.
I'm surprised to hear that people like that box checked. I could never
live with that. But options are there for a purpose, and we're all
different...
 
P

Philip Herlihy

I'm surprised to hear that people like that box checked. I could never
live with that. But options are there for a purpose, and we're all
different...
See if there's a Group- or Local- Policy setting that covers this.
 
W

Wolf K

I'm not running any privacy software. This happened from the outset, with
a fresh OEM install and nothing else installed yet, turning that setting
off while logged in to the administrator account.[...]
Sometimes the following works; not guaranteed, but worth a try:

a) revert setting to default; reboot;
b) change setting as desired; reboot.

This method also occasionally works when a program's custom setting
won't stick.

Good luck.
 
G

Gene E. Bloch

I'm surprised to hear that people like that box checked. I could never
live with that. But options are there for a purpose, and we're all
different...
Mike, you made me realize that my post was messed up :)

I meant it never gets *checked* once I uncheck it (which for me is
always very early in the process of owning a new computer or OS).
 
Ad

Advertisements

B

Bob I

I'm not running any privacy software. This happened from the outset, with
a fresh OEM install and nothing else installed yet, turning that setting
off while logged in to the administrator account.

And I checked the registry keys someone else named. After I change the
settings, the registry *does* reflect the changes ... until the next
reboot. Something is reapplying the Windows factory default values for
those registry keys at boot time, *not* preventing the keys from being
changed to begin with. (Indeed, I don't know if it would work for even
the rest of one session if the keys weren't being changed at all.)
Interesting, so if you change other settings do they "stick"?
 
S

Steve Hayes

Mike, you made me realize that my post was messed up :)

I meant it never gets *checked* once I uncheck it (which for me is
always very early in the process of owning a new computer or OS).
Ah, now that makes sense.

Having it checked seems a recipe for disaster -- you might find yourself
moving or deleting an exe file under the impression that it was a picture or a
document or something.
 
J

J. P. Gilliver (John)

Steve Hayes said:
[]
Mike, you made me realize that my post was messed up :)

I meant it never gets *checked* once I uncheck it (which for me is
always very early in the process of owning a new computer or OS).
Ah, now that makes sense.

Having it checked seems a recipe for disaster -- you might find yourself
moving or deleting an exe file under the impression that it was a picture or a
document or something.
Also, at one time (and probably still to some extent) malware creators
often used double-extensions, such as kitten.jpg.exe; if someone had
show extensions turned off, they might well click on what appeared to
them as kitten.jpg thinking it was a picture (and not wondering why the
..jpg was showing).
 
M

Mike Barnes

Steve Hayes said:
Ah, now that makes sense.

Having it checked seems a recipe for disaster -- you might find yourself
moving or deleting an exe file under the impression that it was a picture or a
document or something.
Not to mention that people can be, and have been, fooled by malware as a
result.

Like Gene, I uncheck that box as the almost the first thing I do with a
new computer. On other people's computers I usually ask permission
first, and they're usually grateful when they see the effect.

I'm disappointed that Microsoft hasn't (yet) seen the stupidity of this
setting and reversed the default. It's been suggested to me that
Microsoft introduced the setting (in XP?) to make Windows seem more like
a Mac, which makes sense if you're panicking because of the Mac threat
and oblivious of the consequences for your users.
 
J

Jesper Kaas

This happened from the outset, with
a fresh OEM install and nothing else installed yet, turning that setting
off while logged in to the administrator account.
Probably not so, but: Are you changing the setting logged in as one
user (administrator), and then when logging in as another user, see no
change? This setting is individual per user.
 
S

Steve Hayes

Not to mention that people can be, and have been, fooled by malware as a
result.

Like Gene, I uncheck that box as the almost the first thing I do with a
new computer. On other people's computers I usually ask permission
first, and they're usually grateful when they see the effect.

I'm disappointed that Microsoft hasn't (yet) seen the stupidity of this
setting and reversed the default. It's been suggested to me that
Microsoft introduced the setting (in XP?) to make Windows seem more like
a Mac, which makes sense if you're panicking because of the Mac threat
and oblivious of the consequences for your users.
The first time I had a computer with that "feature" I was totally lost, and
found it almost unusable. I was trying to set it up and it was like trying to
do it blindfold. Eventually I asked in a forum like this and someone told me
how to turn it off.
 
N

nukid

Interesting, so if you change other settings do they "stick"?
So far as I've noticed, yes. In that I haven't noticed anything else
*not* sticking that I'd expect to stick.
 
N

nukid

Probably not so, but: Are you changing the setting logged in as one user
(administrator), and then when logging in as another user, see no
change?
Nope. Changed these while administrator, rebooted, re-logged in as
administrator, and saw they'd switched off.
 
Ad

Advertisements

D

Dave-UK

nukid said:
Nope. Changed these while administrator, rebooted, re-logged in as
administrator, and saw they'd switched off.
As JJ has suggested, an audit of the reg key might help.
I've had a go myself to see how it's done and here's what
I did to get it working.

First enable auditing:
Administrative Tools > Local Security Policy
Local Policies
Audit Policy
Audit object access > Select 'Success'

Then enable the key:
Regedit
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced
Right-click > Permissions > Advanced > Auditing.
Click on Add...
Type in 'System' and check/tick 'Set Value' under 'Successful'
Then add 'Administrators' and do the same.
OK your way back out.

Then clear the log to start with a clean sheet:
Event Viewer
Windows Logs
Security > Clear log

Now check that it works by changing a value via Folder Options
and then check the Security log in event viewer.
It should flag up explorer.exe as the process that changed the value.
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top