File Type Opening


E

Earl Partridge

Win7 64Bit
I click a .jpg file and am told Unable To Open. The file type .jpg is set
to use Paint Shop Pro. I open Paint Shop Pro and can open the file
with no problem.
What's missing?
Earl
 
Ad

Advertisements

T

Trev

Earl Partridge said:
Win7 64Bit
I click a .jpg file and am told Unable To Open. The file type .jpg is set
to use Paint Shop Pro. I open Paint Shop Pro and can open the file
with no problem.
What's missing?
Earl
Some PSP user's have noted this too. Reset file associations in both Windows
and PSP And it should be ok Then
 
G

Grenou

Earl Partridge said:
Win7 64Bit
I click a .jpg file and am told Unable To Open. The file type .jpg is set
to use Paint Shop Pro. I open Paint Shop Pro and can open the file
with no problem.
What's missing?
Earl
Right-click on the file>Open with: Choose the program you want to use to
open this file.

Ignore what is listed under recommended programs.
Click on Browse, browse to the PSP.exe file (in Programs), then tick 'Always
use the selected program to open this kind of file.
Click OK.

The same thing happened on my husband's computer, I reset everything and so
far (touch wood) all is behaving. :)

Grenou
 
E

Earl Partridge

I've set PSP to be the app to use in file associations in Windows. I don't
find
anywhere in PSP to set the association. My PSP is an older version, 3.12.
Earl
 
E

Earl Partridge

When I right click the .jpg file, then Open With, then "Choose default
programs" then
the Browse. I browsed to where PSP.Exe resides, selected that. Still get
the unable
to open.
Earl
 
D

Dave \Crash\ Dummy

Earl said:
Win7 64Bit I click a .jpg file and am told Unable To Open. The file
type .jpg is set to use Paint Shop Pro. I open Paint Shop Pro and
can open the file with no problem. What's missing? Earl
Is that with all JPG files, or just a particular one? Sometimes alleged
JPG files host illicit code.

I am running PSP 5, which I have been using since Windows 98, on my 64
bit Windows 7 Ultimate system with no trouble whatsoever. I just set the
"preference>File Types" in PSP to all the common formats, including JPEG.
 
E

Earl Partridge

It happens with all .jpg files I've tried to click so far.
In Preferences, I don't have a "File Types". I have General & New Windows.
In General there are Tabs "General", "Loading", "Saving" & "Misc".
There's nothing under either of those tabs close to allowing "File Type"
to be specified.

I'm pretty sure I had this PSP back in Windows 98 also, most recently used
on my XP machine.
Earl
 
R

relic

Earl Partridge said:
It happens with all .jpg files I've tried to click so far.
In Preferences, I don't have a "File Types". I have General & New
Windows.
In General there are Tabs "General", "Loading", "Saving" & "Misc".
There's nothing under either of those tabs close to allowing "File Type"
to be specified.

I'm pretty sure I had this PSP back in Windows 98 also, most recently used
on my XP machine.
Earl
Hit F1, enter 'file association', click on the second link.
 
Ad

Advertisements

D

Dave-UK

Earl Partridge said:
It happens with all .jpg files I've tried to click so far.
In Preferences, I don't have a "File Types". I have General & New Windows.
In General there are Tabs "General", "Loading", "Saving" & "Misc".
There's nothing under either of those tabs close to allowing "File Type"
to be specified.

I'm pretty sure I had this PSP back in Windows 98 also, most recently used
on my XP machine.
Earl
If you are OK with Regedit have a look here:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jpg\UserChoice
and the key for .jpeg.
If you have a UserChoice key try deleting it, it may have corrupted data in it.
It gets re-written by the 'Open with' and 'Choose default program.....' dialog box.
If you would rather not fiddle with the registry yourself go here and download the jpg fix:
http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/
 
E

Earl Partridge

Think I have resolved it. In RegEdit on the XP machine I found where
psp.exe
was set as the default. On this Win7 machine I also found where psp.exe was
set as the default. On the XP machine the file location was NOT in quotes,
whereas
on the Win7 machine the file location (and the %1) were in quotes. I
removed the
quotes and now clicking those .jpg files will open in PSP. ????
Earl
 
D

Dave \Crash\ Dummy

Dave-UK said:
If you are OK with Regedit have a look here:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.jpg\UserChoice


and the key for .jpeg. If you have a UserChoice key try deleting it,
it may have corrupted data in it. It gets re-written by the 'Open
with' and 'Choose default program.....' dialog box. If you would
rather not fiddle with the registry yourself go here and download the
jpg fix:
http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/
IMHO, the best all around file type association manager. It allows
adding multiple menu items, like "open," "edit," "edit with", etc.,
using multiple programs.

http://www.nirsoft.net/utils/file_types_manager.html
 
D

Dave-UK

Dave "Crash" Dummy said:
IMHO, the best all around file type association manager. It allows
adding multiple menu items, like "open," "edit," "edit with", etc.,
using multiple programs.

http://www.nirsoft.net/utils/file_types_manager.html
If you like Nirsoft stuff get the full package:
http://launcher.nirsoft.net/
After downloading and extracting run AlternateStreamView and remove
all the alternate data streams (unblock) from the files in the Nirsoft folder.
Then the help files will display correctly from the program.
 
C

Char Jackson

Think I have resolved it. In RegEdit on the XP machine I found where
psp.exe
was set as the default. On this Win7 machine I also found where psp.exe was
set as the default. On the XP machine the file location was NOT in quotes,
whereas
on the Win7 machine the file location (and the %1) were in quotes. I
removed the
quotes and now clicking those .jpg files will open in PSP. ????
Earl
If the path has spaces in it, the quotes may be required. Without
spaces, the quotes should be optional. If quotes are used, however,
they should never enclose the extra parameters (%1, for example).

In your case, it looks like the problem was that the %1 parameter was
accidentally enclosed in the quotes.
 
Ad

Advertisements

G

Grenou

Wow, I am amazed that you can run that version of Paint Shop Pro on a
Windows 7 machine!

Grenou
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top