Canon scanner 8400F driver problem


Joined
Dec 11, 2010
Messages
9
Reaction score
0
win7 64-bit:

Alright, I HAD the scanner working & it stopped with the toolbox claiming that it could not open the twain driver & to etc..... & needed the WIA driver.

WHY??? I had used the scanner to scan an image about 14 days ago & now it stopped! In the meantime, I got a Monoprice 27" monitor & an ASUS HD7790 card & installed the associated latest amd driver.

Also, some win7 updates in between along with a *.net update.

So any idea whether it is the ati 7790 graphics card or microsoft killing the use of the scanner? Or even better, what scanner is supporting win7/win8 in 64-bit? Any info regarding the Brother's line of scanners?

I no longer have any hair to pull out:)
 
Ad

Advertisements

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,319
Reaction score
1,584
I would uninstall the printer driver and download the one from Canon. Reboot and then install.

It is possible the driver you had was "updated" by Windows Update, if so then after you install the proper driver the problem will likely return with the next windows update unless you manually run Windows Update and "hide updates" for your printer.
WinUpdt-HideOptions.jpg

It should not be related to your new video card or monitor at all, those would be "video" drivers not "printer".
 
Joined
Dec 11, 2010
Messages
9
Reaction score
0
Back again....forgot to add that the drivers do install! It is just the canon toolbox was not able to open the twain driver??? another windows security problem created by microsoft?

Trying to install the "wia" driver gets a "no wia device found on the system"; so much for the prompt to install the wia.

Or did microsoft took over doing the scanner drivers also like they did for usb 3 drivers & screwed that up? The canon site says there are no drivers or software for windows 8; end of the line/life for the 8400F........

At least, my MacMini was able to scan the docs I wanted & sent them.
 
Joined
Dec 11, 2010
Messages
9
Reaction score
0
Stumbled onto a solution; can't find it again but it works.

The problem is that the drivers were NOT in the environment path & either a win7 update/security changed something about where to look for the scanner drivers. Edited the env path to include c:\windows\twain_32\(canon's installation name of the drivers)

Rebooted & the 8400f scanner now works as usual. The problem could be the same for other scanners when the twain drivers "could not be opened".

The last security update probably killed the scanner's ability to open/use the twain scanner drivers.
 
Ad

Advertisements

Joined
Jan 13, 2017
Messages
2
Reaction score
0
Stumbled onto a solution; can't find it again but it works.

The problem is that the drivers were NOT in the environment path & either a win7 update/security changed something about where to look for the scanner drivers. Edited the env path to include c:\windows\twain_32\(canon's installation name of the drivers)

Rebooted & the 8400f scanner now works as usual. The problem could be the same for other scanners when the twain drivers "could not be opened".

The last security update probably killed the scanner's ability to open/use the twain scanner drivers.
Hi Paul
What is the complete env path entry for the 8400F? It seems to be different for each scanner model.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top