Windows 7 Multiple networks at startup - no internet access


Joined
Jan 21, 2010
Messages
2
Reaction score
0
Hi all, having an issue with an otherwise GREAT OS being every time I start my pc, I can't connect to the net because it's showing as being connected to multiple networks.

I have Windows 7;
A wireless modem router with 4 ports
A laptop running Vista that connects wirelessly with no issues
A pc with no wireless card connected with ethernet cable. This is where the issue is. EVERY time I start the pc up, it can't connect to the internet because there are multiple networks. A Home network and an Unidentified network.

How do I resolve this problem?
 
Ad

Advertisements

Joined
Nov 30, 2009
Messages
9
Reaction score
0
Hi

Apparently there is an Apple program called "Bonjour Services" it is installed in Windows 7 with programs like iTunes.

It is also installed with Adobe PS3 programs but usually shows up as ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## in Adobe.


To see if you have the Bonjour service or ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## running on your PC.

Click Start
Right-click "Computer" and select "Manage".
Expand "Services and Applications"
Click "Services".
Find the Bonjour name or ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## in the list of services.
Double-click this to open up a Window.
Under the General Tab next to Start-up Type Select Disabled from the drop down.
Now test and see if you still have connectivity issues.

Jessie
 
Joined
Jan 21, 2010
Messages
2
Reaction score
0
Hi Jessie,

Thank you very much! I have had technicians trying for a week 1/2 to correct this issue with no results.

Cynthia
 
Joined
Jan 11, 2010
Messages
168
Reaction score
10
I haven't had trouble wit bonjor Services. So Thats weared.
 
Joined
Dec 4, 2010
Messages
1
Reaction score
3
The Real Solution for this issue

I just figured this out finally after long hours, I thought after that long I would post so others dont have to go through all of it-

If you DO NOT have the Bonjour service running or present (it will be if you have iTunes or some Adobe products installed)

I am using Windows 7 Professional

To run two networks, one with Internet access and one without (in my case, one wireless adapter with Internet access, and a wired connection for local server access), you will need to change the Metric of your wireless adapter to be lower than that of your wired adapter.

The wired connection will have priority over the wireless one by default, so basically any time you want to surf the net Windows will look at the wired connection first, which in my case goes nowhere, based on this metric. The default metric of the wired adapter was 10, and the wireless was 25 (to check this, go to your Command Prompt and type "route print" (no quotes), and look at the IPv4 list.

To change this, go into your adapter's properties page, under IPv4 go to Properties, then Advanced. You will see a little area that says "Automatic Metric".

For the adapter you want to have priority for Internet connectivity, uncheck this and enter 1, and close out of the properties windows.

This will force Windows to look at that adapter first before any other. I did this and it worked like a charm. Hopefully this post saves someone some headache. I suspect this works for Vista as well as it is fundamentally the same as 7 under the hood.

-Breach
 
Joined
Feb 14, 2011
Messages
1
Reaction score
0
Adobe CS3

I had same problem (Win7 Ultimate), after 2 days I found this thread and yep, indeed it seemed to have been caused by Adobe CS3 and the service, just stopped the service, rebooted and all is back to normal !

Thanks for the solution Jessie

D.
 
Ad

Advertisements

Joined
Apr 3, 2011
Messages
1
Reaction score
0
Thanks, Breach -- you nailed it for me! :beer:
It seems rather silly that Win7 is smart enough to tell me that my wireless connection has internet access while my LAN connection does not, but then it stupidly tries to access the internet via the LAN connection. I think the troubleshooting wizard at least should check for something as simple as a conflicting metric setting... are you listening Microsoft? :confused:
 
Joined
Aug 28, 2011
Messages
2
Reaction score
0
Hi

Apparently there is an Apple program called "Bonjour Services" it is installed in Windows 7 with programs like iTunes.

It is also installed with Adobe PS3 programs but usually shows up as ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## in Adobe.


To see if you have the Bonjour service or ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## running on your PC.

Click Start
Right-click "Computer" and select "Manage".
Expand "Services and Applications"
Click "Services".
Find the Bonjour name or ##Id_String1.6844F930_1628_4223_B5CC_5BB94B879762## in the list of services.
Double-click this to open up a Window.
Under the General Tab next to Start-up Type Select Disabled from the drop down.
Now test and see if you still have connectivity issues.

Jessie

I went in and tried this suggestion and actually got on line immediately. So it appears to be the problem. One question as I am not a computer expert. Will my adobe work and will my daughter still be able to download itunes??

Thank you for you help.:)

disconnected JIm
 
Joined
Nov 5, 2012
Messages
1
Reaction score
0
This works - Wifi to Internet, LAN to intranet

Thanks, after many versions of the truth this works on W7 x64, Apple iTunes installed,

I just figured this out finally after long hours, I thought after that long I would post so others dont have to go through all of it-

If you DO NOT have the Bonjour service running or present (it will be if you have iTunes or some Adobe products installed)

I am using Windows 7 Professional

To run two networks, one with Internet access and one without (in my case, one wireless adapter with Internet access, and a wired connection for local server access), you will need to change the Metric of your wireless adapter to be lower than that of your wired adapter.

The wired connection will have priority over the wireless one by default, so basically any time you want to surf the net Windows will look at the wired connection first, which in my case goes nowhere, based on this metric. The default metric of the wired adapter was 10, and the wireless was 25 (to check this, go to your Command Prompt and type "route print" (no quotes), and look at the IPv4 list.

To change this, go into your adapter's properties page, under IPv4 go to Properties, then Advanced. You will see a little area that says "Automatic Metric".

For the adapter you want to have priority for Internet connectivity, uncheck this and enter 1, and close out of the properties windows.

This will force Windows to look at that adapter first before any other. I did this and it worked like a charm. Hopefully this post saves someone some headache. I suspect this works for Vista as well as it is fundamentally the same as 7 under the hood.

-Breach
 
Ad

Advertisements

Joined
Dec 5, 2012
Messages
1
Reaction score
0
Hard to find, but great solution...

I just figured this out finally after long hours, I thought after that long I would post so others dont have to go through all of it-

If you DO NOT have the Bonjour service running or present (it will be if you have iTunes or some Adobe products installed)

I am using Windows 7 Professional

To run two networks, one with Internet access and one without (in my case, one wireless adapter with Internet access, and a wired connection for local server access), you will need to change the Metric of your wireless adapter to be lower than that of your wired adapter.

The wired connection will have priority over the wireless one by default, so basically any time you want to surf the net Windows will look at the wired connection first, which in my case goes nowhere, based on this metric. The default metric of the wired adapter was 10, and the wireless was 25 (to check this, go to your Command Prompt and type "route print" (no quotes), and look at the IPv4 list.

To change this, go into your adapter's properties page, under IPv4 go to Properties, then Advanced. You will see a little area that says "Automatic Metric".

For the adapter you want to have priority for Internet connectivity, uncheck this and enter 1, and close out of the properties windows.

This will force Windows to look at that adapter first before any other. I did this and it worked like a charm. Hopefully this post saves someone some headache. I suspect this works for Vista as well as it is fundamentally the same as 7 under the hood.

-Breach
I joined the site just to plug this solution. I've been scratching my head over this for the last 2 months and finally decided to start entering random combinations of 2 networks, internet not working, etc, on search sites.

This is a great solution for "windows 7 internet priority with multiple network connections", or "wireless internet on windows 7 while connected to wired network". I had actually gotten to the point where I would disconnect the wired connection to sync mail/etc. Other versions (hoping the search engines pick these up): "how to force windows 7 to use the wireless connection for internet", "configuring internet connection on windows 7 with multiple network connections".

As an example of a solution that should, but does not work, I found a site that showed me how to set the priority of my network connections by accessing the advanced settings under the Network Connections panel (by hitting alt to bring up the menu then selecting Advanced->Advanced Settings and changing the "order"). It doesn't work. Breach's solution works.

Hope this helps more people find this solution faster rather.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top