Windows 7 Aero


Fire cat

Established Member
VIP Member
Joined
Mar 7, 2010
Messages
1,157
Reaction score
191
Well, I guess nobody can be immune to Windows problems :(
I've installed Windows 7 Professionnal (32bit) inside a VirtualBox VM (on Mac). Got it to install, works fine, activated fine, installs software fine, etc.

BUT Aero doesn't work. I've installed the VirtualBox "drivers" (you know, "VirtualBox Guest Additions" thing), which should in theory enable aero, but it doesn't. Which is weird, since the rest of the "guest additions" work fine.

What could I do? Tried the regedit edit, but that didn't work. Windows tells me that the hardware is compatible, but needs drivers.

Wat.
 
Ad

Advertisements

Core

all ball, no chain
Moderator
Joined
Feb 13, 2009
Messages
1,175
Reaction score
272
Dumb question I'd imagine, but have you enabled 3D acceleration?
 

Elmer BeFuddled

Resident eejit
VIP Member
Joined
Jun 12, 2010
Messages
1,050
Reaction score
251
I'm guessing here, but could it have anything to do with the amount of RAM you've allocated to the VM? I know mine doesn't work with 1GB 'allocated'.
 

Core

all ball, no chain
Moderator
Joined
Feb 13, 2009
Messages
1,175
Reaction score
272
Try VMWare Fusion, it should have better support for Aero and graphics acceleration.
 
Ad

Advertisements

Joined
Aug 20, 2011
Messages
1
Reaction score
0
No Basic

Make sure when installing the Guest Additions for DirectX answer the question correctly. (Don't choose default. Choose NO! you do not want basic (and yes you want the expiremental DirectX drivers)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top