USB 2.0 thumb drives NOT being recognized or acknowledged

Discussion in 'Drivers' started by speedracer, Nov 29, 2017.

  1. speedracer

    speedracer

    Joined:
    Nov 29, 2017
    Messages:
    1
    Likes Received:
    0
    Hello all. This one is driving me crazy. I have a 250 gig SSD drive and cloned it to a 500 gig SSD drive. When I put a thumb drive into any of the usb slots with the 250 gig drive the system recognizes it and then I can eject it. When I use the 500 gig drive I get a tone but the drive does not come up in 'COMPUTER'. I can go to drive management and it's also not there. When I go to device manager I have a little exclamation mark next to the thumb drive. I have tried UNINSTALLING the device and then click on SCAN FOR CHANGES. I get the box that drivers are being installed but when I open the box it says driver install FAILED. The driver is "USB 2.0 FD USB device driver". When I click on the UPDATE DRIVER on that device it comes up with WINDOWS SAYS YOU ARE RUNNING THE BEST DRIVER - although NO driver is installed. RIGHT!! I really, really don't want to do an install from scratch and install all the programs and updates and data unless I absolutely have to. SO, my questions to any of you are: (a) IF it was cloned (with no error msgs) then why does it work on the source but NOT the destination? (b) What driver do I need to install and where is it located, and HOW do I get it installed as no floppy and if it wont recognize ANY thumb drive that pretty much limits my install method choices. Oh, one last note, I tried Microsoft's troubleshooting wizard for devices and printers(?) and it found the device driver error but it also could NOT install the driver. ALL HELP will be greatly appreciated. THANKS..
     
    speedracer, Nov 29, 2017
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.