NAS drive invisible to file/open AND iTunes (but visible in Explorer)

Nov 5, 2016
Reaction score
I have a weird problem that has me completely baffled. I have a WD MyBook NAS drive that appears to work perfectly in that I can open it in Windows Explorer and access all the files it contains. However, it is invisible in the file / open dialog of all MS Office applications - and similarly, if I try to point iTunes to the iTunes Media folder that the drive contains, it does not appear among the network resources there, either.

I have succeeded in pointing iTunes at the drive by inputting the path instead (it is \\ and my library updated - which was promising. But when I tried to play a song, it said that the file could not be located. Tried to locate it, and once again, iTunes could not see the device.

I have another laptop (running Windows 10) which doesn't have the problem - which would perhaps indicate that there is nothing wrong with the way in which the drive is configured and that instead, there is some setting on the Windows 7 box which is preventing programs from accessing the drive in the normal way.

Anyone have any thoughts? I am using a Netgear R8000 router and have Trend Micro OfficeScan 11 installed on the machine, which is running Windows 7 Enterprise SP1.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question