Change default installation path [Windows 7]


Joined
May 6, 2009
Messages
2
Reaction score
0
How do I change the default install/common files path in windows 7?
It's default is: C:\Program Files & C:\common files

I've done this before several times in xp en vista, using this edit in regedit:

Change the settings in this registry key: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion

From C:\blablabla to whatever drive you want, D: in my case.

My problem: This doesnt work in Windows 7...

Who knows the solution?

Thanks a million!
 
Ad

Advertisements

Joined
May 19, 2009
Messages
27
Reaction score
1
The way, that you described seems to work on the 32-bit Windows7,
but not on 64-bit Version because there are two Versions on "regedit.exe" there.

The Solution is, to change the registry in the second version either:

1.) Enter into Start>Run: %systemroot%\syswow64\regedit
2.) Go to: HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion
3.) Change the Path in DWORDs ProgramFilesDir, ProgramFilesDir (x86) from "C:\Program Files (x86)" to your own.
 
Joined
Nov 12, 2009
Messages
3
Reaction score
0
I did the above and it worked fins using the 64bit regedit, however, program installer opens, It installes to the dir i changed it to "E:\Program Files\", but once installer is finished i can not open the prog via its icon either from the desktop or from the start menu, I veiw the Icon properties, and find that the target is still "C:\Program Files (x86)\...." I correct it and everthing works fine, But its a pain, and I can not find anywere else in the registry to change the %ProgramFiles(x64)% Variable, witch im assuming is causeing the issue, and there are no entries for this varable in Sytem properties.... can anyone help?!
 
Joined
Sep 16, 2012
Messages
2
Reaction score
0
Hi

It's a long time since your post but did you ever get an answer? I've changed the Prog File path with no problem but when I change the Prog File x86 path various programs won't work (Invalid path). Puth the x86 path back to C: and all's well.

Andy
 
Joined
Nov 12, 2009
Messages
3
Reaction score
0
Hi

It's a long time since your post but did you ever get an answer? I've changed the Prog File path with no problem but when I change the Prog File x86 path various programs won't work (Invalid path). Puth the x86 path back to C: and all's well.

Andy
No that was a bit ago, I just manually changed the target in the Icon, Ive since changed my install a few times, also, If you add for exaple D:/Program files(x86) to PATH varable that helped me as well (replace D: for your root drive). Path is in varable in system properties---->Advanced system settings---->Enviroment varables on the bottom of the "Advanced" tab

Hope this helps

0n3
 
Ad

Advertisements

Joined
Nov 12, 2009
Messages
3
Reaction score
0
forgot..... just add the varable to the endo f the path if its not already there... use a , (comma) to seperate the values eg PATH=c:/windows,D:/Program files(x86)
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top