Change Default Target Folder For Windows Explorer


T

tb

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.

I now would like to be able to either click on the Desktop shortcut or
the Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).

I right-clicked the Desktop shortcut, selected Properties, and inserted
the following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip

I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip

But they both don't work as they open to Computer instead! The funny
thing is that I have another desktop with the same OS (except that it is
32-bit) and the above commands work just fine...

Does anyone know what I need to do?

Thanks.
 
Ad

Advertisements

T

Tony Vella

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.

I now would like to be able to either click on the Desktop shortcut or
the Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).

I right-clicked the Desktop shortcut, selected Properties, and inserted
the following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip

I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip

But they both don't work as they open to Computer instead! The funny
thing is that I have another desktop with the same OS (except that it is
32-bit) and the above commands work just fine...

Does anyone know what I need to do?

Thanks.
I created a shortcut on the desktop and selected a target folder. Then
I dragged the icon to the quick-launch and they both work exactly the
same. I too have Windows 7 Home Premium SP1 (64-bit). Hope this helps.
 
G

Gene E. Bloch

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also created
a Quick-Launch shortcut for it.
I now would like to be able to either click on the Desktop shortcut or the
Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).
I right-clicked the Desktop shortcut, selected Properties, and inserted the
following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip
I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip
But they both don't work as they open to Computer instead! The funny thing
is that I have another desktop with the same OS (except that it is 32-bit)
and the above commands work just fine...
Does anyone know what I need to do?
Since that syntax seems to work fine here, I wonder if you don't have
quite what you think you have for the targets. As in an unnoticed
typo...

Try this: click in Target in the shortcut properties, Select All
(Ctrl-A), then copy and paste it into a text editor. That will make it
easy to see something odd.

One thing I am thinking of is maybe you typed your target without
clearing what might have already been present.

For instance, as a test, I just typed this:

%windir%\explorer.exe %windir%\explorer.exe C:\Temp\Download

and the shortcut now takes me to My Documents...
 
G

Gene E. Bloch

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.
I now would like to be able to either click on the Desktop shortcut or the
Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).
I right-clicked the Desktop shortcut, selected Properties, and inserted the
following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip
I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip
But they both don't work as they open to Computer instead! The funny thing
is that I have another desktop with the same OS (except that it is 32-bit)
and the above commands work just fine...
Does anyone know what I need to do?
Since that syntax seems to work fine here, I wonder if you don't have
quite what you think you have for the targets. As in an unnoticed
typo...

Try this: click in Target in the shortcut properties, Select All
(Ctrl-A), then copy and paste it into a text editor. That will make it
easy to see something odd.

One thing I am thinking of is maybe you typed your target without
clearing what might have already been present.

For instance, as a test, I just typed this:

%windir%\explorer.exe %windir%\explorer.exe C:\Temp\Download

and the shortcut now takes me to My Documents...
 
G

Gene E. Bloch

Since that syntax seems to work fine here, I wonder if you don't have quite
what you think you have for the targets. As in an unnoticed typo...
Try this: click in Target in the shortcut properties, Select All (Ctrl-A),
then copy and paste it into a text editor. That will make it easy to see
something odd.
One thing I am thinking of is maybe you typed your target without clearing
what might have already been present.
For instance, as a test, I just typed this:
%windir%\explorer.exe %windir%\explorer.exe C:\Temp\Download
and the shortcut now takes me to My Documents...
Anyone know a cure for hiccups?

:)
 
Z

Zaidy036

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.
<snip>

1. Open Win Expl to the folder you want.
2. In the address bar drag th folde icon to the desk top
3. Rename as you want.
4. Copy to Q-L
 
Ad

Advertisements

T

tb

1. Open Win Expl to the folder you want.
2. In the address bar drag th folde icon to the desk top
3. Rename as you want.
4. Copy to Q-L
Unfortunately it still only opens to Computer when I click on the icon
created to Desktop.
 
T

tb

Since that syntax seems to work fine here, I wonder if you don't have
quite what you think you have for the targets. As in an unnoticed typo...
Believe me, I checked and double-checked the syntax many times but
cannot find anything wrong with it.
Try this: click in Target in the shortcut properties, Select All
(Ctrl-A), then copy and paste it into a text editor. That will make it
easy to see something odd.
This is the pasted result:
C:\Windows\explorer.exe C:\Temp\downloads\unzip
....which is exactly what I have in the Target box of the shortcut.
 
Z

Zaidy036

Unfortunately it still only opens to Computer when I click on the icon
created to Desktop.
use this target: %SystemRoot%\explorer.exe /e,%USERPROFILE%\Desktop

Note the " /e,"
 
C

Char Jackson

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.

I now would like to be able to either click on the Desktop shortcut or
the Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).

I right-clicked the Desktop shortcut, selected Properties, and inserted
the following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip

I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip

But they both don't work as they open to Computer instead! The funny
thing is that I have another desktop with the same OS (except that it is
32-bit) and the above commands work just fine...

Does anyone know what I need to do?
Does the traditional approach not work any longer?

<http://support.microsoft.com/kb/130510>

I would try this in the Target box:
C:\Windows\explorer.exe /e,C:\Temp\downloads\unzip

Paths with spaces would require quotation marks, as in:
C:\Windows\explorer.exe /e,"C:\Temp\down loads\unzip"
 
Ad

Advertisements

E

Ed Cryer

tb said:
I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.

I now would like to be able to either click on the Desktop shortcut or
the Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).

I right-clicked the Desktop shortcut, selected Properties, and inserted
the following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip

I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip

But they both don't work as they open to Computer instead! The funny
thing is that I have another desktop with the same OS (except that it is
32-bit) and the above commands work just fine...

Does anyone know what I need to do?

Thanks.
Go to the folder in question and select a file in it. Right click, Send
to Desktop (shortcut).
Go to desktop, right click the shortcut, Properties, and edit out the
file name from the end, so that it concludes with the folder name; apply.
Rename shortcut as you will, and move it anywhere.

Ed
 
G

Gene E. Bloch

Believe me, I checked and double-checked the syntax many times but cannot
find anything wrong with it.
This is the pasted result:
C:\Windows\explorer.exe C:\Temp\downloads\unzip
...which is exactly what I have in the Target box of the shortcut.
OK, your command is fine, and something weird is wrong, as you imply.

I know I have made dumber mistakes than what I was pointing to, so I'm
sorry it didn't end up so easy for you :-(

Unless your temp directory has a different name...sorry, I just
couldn't let it go :)
 
G

Gene E. Bloch

Does the traditional approach not work any longer?

I would try this in the Target box:
C:\Windows\explorer.exe /e,C:\Temp\downloads\unzip
Paths with spaces would require quotation marks, as in:
C:\Windows\explorer.exe /e,"C:\Temp\down loads\unzip"
It may have changed. What I did before replying to tb was to do what he
did, and it worked fine for me.

By changed, I don't mean the old way is gone, but that the new way has
been added.

OK, I just tested it; your method (it's also Zaidy036's) still works,
but so does this:

Set the target to "C:\Temp\Download" with no reference to explorer.exe.

as Ed Cryer suggests - but I did it another way: I just did
Shift-Right-Click on the folder name and copied it as path, so I could
paste it into a shortcut.

The last one pins to the context menu of the Explorer's existing
Taskbar icon, not as a Taskbar icon in its own right.
 
Ad

Advertisements

T

tb

Go to the folder in question and select a file in it. Right click, Send
to Desktop (shortcut).
Go to desktop, right click the shortcut, Properties, and edit out the
file name from the end, so that it concludes with the folder name; apply.
Rename shortcut as you will, and move it anywhere.

Ed
It still opens to Computer.

It makes me so mad because it works with the other desktop...
 
T

tb

I would try this in the Target box:
C:\Windows\explorer.exe /e,C:\Temp\downloads\unzip

Paths with spaces would require quotation marks, as in:
C:\Windows\explorer.exe /e,"C:\Temp\down loads\unzip"
They both still open to Computer.
 
T

tb

I have Windows 7 Home Premium SP1 (64-bit) installed.
I have created a Desktop shortcut for Windows Explorer. I have also
created a Quick-Launch shortcut for it.

I now would like to be able to either click on the Desktop shortcut or
the Quick-Launch icon and have Windows Explorer automatically open to:
C:\Temp\downloads\unzip
(this is just a few custom folders that I have created on my PC).

I right-clicked the Desktop shortcut, selected Properties, and inserted
the following in the Target box:
C:\Windows\explorer.exe C:\Temp\downloads\unzip

I right-clicked the Quick-Launch icon, right-clicked Windows Explorer,
selected Properties, and inserted the following in the Target box:
%windir%\explorer.exe c:\Temp\downloads\unzip

But they both don't work as they open to Computer instead! The funny
thing is that I have another desktop with the same OS (except that it is
32-bit) and the above commands work just fine...

Does anyone know what I need to do?

Thanks.
I finally figured out how to solve the problem...

Start -> Control Panel -> Appearance and Personalization -> Folder
Options. Under the General tab, in the Navigation Pane section, make
sure that the option "Automatically expand to current folder" is selected.

That was what was preventing Windows Explorer from opening the target
folder.
 
Ad

Advertisements

C

Char Jackson

They both still open to Computer.
It makes me a bit nervous when basic functionality turns up broken.
What other problems is this computer having? If none, I wonder what's
lurking that simply hasn't been discovered yet.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top