SOLVED Intellimouse Optical buttons can't be changed


Joined
Jan 15, 2010
Messages
3
Reaction score
0
I have a totally new problem with my MS Intellimouse Optical. I have used this for some time (98, ME, XP) with no problems. I now have a new system - Windows 7 Home Premium 64 bit. I have downloaded and installed the latest Intellipoint software (7) from Microsoft, and installed the Mouse. But...
- The Mouse is recognised not as an Intellimouse Optical, but an Intellimouse Web
- I cannot therefore change the side button settings on the mouse (via Control Panel>Mouse) from the default "Forward" and "Back", or the centre button either.
This is annoying. I have uninstalled and reinstalled a number of times, to no avail.

Does anyone know...??
(a) How to get Windows 7 to recognise my mouse as the proper type (Device Manager etc)....or
(b) How to hack the settings (XML / Registry / whatever) to change the default option, so the mouse does what I want it to without trying to change the buttons via the Control Panel.

Many thanks
 
Ad

Advertisements

Joined
Jan 14, 2010
Messages
4
Reaction score
1
When I upgraded to W7 a few months ago Microsoft made it clear that the mouse and keyboard drivers were new and had to be downloaded. Mine is a different one and you said you downloaded the new drivers but just for fun I went to the download site and the Intellimouse Web is RIGHT BELOW your intellimouse Optical! Could you have downloaded the wrong driver? It's awful easy to let the pointer slip down a line. Check it out. MS is pretty good with these peripherals.

I have a totally new problem with my MS Intellimouse Optical. I have used this for some time (98, ME, XP) with no problems. I now have a new system - Windows 7 Home Premium 64 bit. I have downloaded and installed the latest Intellipoint software (7) from Microsoft, and installed the Mouse. But...
- The Mouse is recognised not as an Intellimouse Optical, but an Intellimouse Web
- I cannot therefore change the side button settings on the mouse (via Control Panel>Mouse) from the default "Forward" and "Back", or the centre button either.
This is annoying. I have uninstalled and reinstalled a number of times, to no avail.

Does anyone know...??
(a) How to get Windows 7 to recognise my mouse as the proper type (Device Manager etc)....or
(b) How to hack the settings (XML / Registry / whatever) to change the default option, so the mouse does what I want it to without trying to change the buttons via the Control Panel.

Many thanks
 
Joined
Mar 22, 2009
Messages
47
Reaction score
11
Go to the Control panel and select Mouse. You should be able to select your mouse from the drop down menu under connected device.
 
Joined
Jan 15, 2010
Messages
3
Reaction score
0
Thanks for this. However, that's the whole point. When I do this, and select my mouse model and allocate the buttons, it has no effect whatsoever - the buttons stay on their default settings.

Does anyone know how to edit the relevant registry entries / documents to change these default button settings?
 
Joined
Oct 6, 2011
Messages
5
Reaction score
0
Intellimouse Optical won't reassign side buttons

Hi,

I have the same problem with the Intellimouse Optical not wanting tot reassign it's side buttons in Windows 7 home premium!

I have uninstalled the drivers several times and even downloaded the newest Intellimouse 8.2 software from Microsoft. However, the side buttons still refuse to be reassigned though with the Intellimouse software at least the options appear as W7 own driver doesn't even recognise there are side buttons! Further I've noted that in the device manager W7 describes my mouse as Microsoft USB IntelliMouse Web.... not Optical.

Can anyone suggest what to do? I don't want to install third party software... surely there is a Microsoft fix?

I read in a forum that if I search for oem*.inf and
[FONT=&quot]ipfilter.inf on the computer, and then delete them and reinstall then this solves the problem... however, I'm not sure what these are and don't want to delete stuff without knowing what they do. When I searched about 15 oem files came up.

Any help would be deeply appreciated!

Many thanks,

Judd

[/FONT]
 
Joined
Oct 6, 2011
Messages
2
Reaction score
0
I have also experienced the issue of not being able to reassign Intellimouse Optical buttons (I use it left handed) and have been working around it for a couple of years now. I just found the solution at http://www.sevenforums.com/1286453-post6.html !

As you noticed, the problem appears to be caused by Windows not installing the correct device driver for this mouse model. The solution for me was to use device manager to manually install the correct "Microsoft USB intellimouse optical (intellipoint)" driver. The linked post includes more details.


Hi,

I have the same problem with the Intellimouse Optical not wanting tot reassign it's side buttons in Windows 7 home premium!
...
 
Ad

Advertisements

Joined
Oct 6, 2011
Messages
5
Reaction score
0
Hi Michael902,

thank you very much!!! However, I went to the link but it was unclear what to do... it says I was able to change to optical by updating the ,'... what is meant by that? How exactly do I do it? Do I uninstall the driver and software I have now and then choose somewhere?

Sorry if I'm missing something obvious!

Judd
 
Joined
Oct 6, 2011
Messages
5
Reaction score
0
Ahhh Micheal,

worked out how to do it... but it still won't let me reassign the side buttons!!! They just stay with the default back and forward. At least in device manager it's 'optical' instead of 'web' now!! :/

Any ideas?

Judd

Thanks...
 
Joined
Oct 6, 2011
Messages
2
Reaction score
0
All button reasignments are working fine for me since I changed to the correct mouse driver. This also resolved an issue I was having with left hand mouse control in remote desktop sessions.

I have the latest Intellipoint (8.2) for Windows 7 64-bit installed. In the mouse control panel, the connected device shows as "Intellimouse Optical".
 

TrainableMan

^ The World's First ^
Moderator
Joined
May 10, 2010
Messages
9,321
Reaction score
1,584
judd, have you installed the X-mouse button control option from the link walrus listed? He said that is what solved his problem.

I will repeat the link here.
 
Joined
Oct 6, 2011
Messages
5
Reaction score
0
Michael, I got it working!! There were two drivers 'Microsoft Intellimouse Optical and 'Microsoft Intellimouse Optical (Intellimouse)'!!! I tried the latter and it worked!

Thank you so much!!! :eek:)

All the best,

Judd
 
Ad

Advertisements

Joined
Oct 6, 2011
Messages
5
Reaction score
0
Thanks Trainableman,

I got it working eventually using Michael's tip... thanks anyway!!!

Best wishes,

Judd
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top