“Bootmgr is missing” using Zip Drive

Mar 17, 2023
Reaction score
Hello all,

I am having a “Bootmgr is missing”issue.

I have an older Windows 7 PC that I just installed an Iomega 100 Zip drive on. The BIOS recognizes the Zip drive, but when I turn on the computer, I get the “bootmgr is missing” message and the machine will not start.

However, when I remove the Zip drive, the computer boots up fine. I have tried three different Zip drives and none allow the computer to start. Bootmgr is missing consistently on all three Zip drives.

The BIOS is set up properly. The CD rom is first to boot and then the hard drive. Again, the BIOS recognizes the Zip drive.

I searched the computer for the Bootmgr file but could not locate it. However, it is in the system because the computer does indeed start when the Zip drive is not connected.

The Zip drive is set to “Master” because there is no other device on its cable. The cable is new.

I looked for a BIOS update but could not locate one. It is an Award BIOS version 6.00. The desktop machine is an older Gigabyte K8NS main board with an Athlon 64 processor. 32 bit system.

I’ve gone thru the command prompt with various instructions to make repairs, but no luck. I have loaded the Windows 7 CD and done a “Repair the Computer”, but no luck either.

I tried a “Repair Computer” using the Windows install CD but no luck.

Then I did a complete reinstall of Windows and still have the same issue. Bootmgr is missing whenever the Zip is connected.

Does anyone have any ideas on what the problem might be and how to fix it?

Thanks all.

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question