The Audio Service Is Not Running


J

JCO

OS: Windows 7 with all updates;
Message: The Audio Service Is Not Running

Every time I boot the computer, my speaker system has the red "X" next to
it. However, the sound is still working just fine. If I mute it then
un-mute it, the "x" goes away. In fact, if I change the volume it also goes
away. When I mouse over the Speaker Icon (lower right corner), while the
Rec "X" is there, I get the message above.

I don't have any driver issue at all. I don't know what Service, the
message is referring too. I don't see a service called "Audio".

Obviously this is not that serious since the sound is working fine, but if
anyone has an idea, I would like to fix it.

Thanks
 
Ad

Advertisements

G

Gene E. Bloch

OS: Windows 7 with all updates;
Message: The Audio Service Is Not Running

Every time I boot the computer, my speaker system has the red "X" next to
it. However, the sound is still working just fine. If I mute it then
un-mute it, the "x" goes away. In fact, if I change the volume it also goes
away. When I mouse over the Speaker Icon (lower right corner), while the
Rec "X" is there, I get the message above.

I don't have any driver issue at all. I don't know what Service, the
message is referring too. I don't see a service called "Audio".

Obviously this is not that serious since the sound is working fine, but if
anyone has an idea, I would like to fix it.

Thanks
The service is called Windows Audio and it *is* listed in the Services
app.

My fix has been to open Services, scroll to the app, right click, and
choose Restart.

With any luck, in future I'll remember your much easier approach :)

BTW, it happens to me relatively infrequently. Lucky me, I guess.
 
C

charlie

The service is called Windows Audio and it *is* listed in the Services
app.

My fix has been to open Services, scroll to the app, right click, and
choose Restart.

With any luck, in future I'll remember your much easier approach :)

BTW, it happens to me relatively infrequently. Lucky me, I guess.
I had a sound oddity occur this morning.
MBD RealTec audio
Video Cards HD7770 (two) in crossfire.
Win 7 32

Update to video drivers ver 13.1
When update to video(and AMD video card audio) was completed,
The MBD Realtec sound drivers were activated and made default
The AMD HDMI audio output to the LCD display was inop.
On the AMD "vision engine control center", display #1 was nonexistent,
even though it's the active display and the only one installed.

Remember that there are actually three sets of audio drivers on this
P/C- Microsoft's windows drivers, Realtec drivers, and the AMD drivers.

1. Disabled the MBD audio system in BIOS
(Did not solve the problem, but did reduce the complexity.)

Went back to the AMD video driver installer, and, using custom,
uninstalled the AMD audio driver. Exited the installer.
Lo and behold, a windows notification popup said that an audio driver
was being installed (by windows)
HDMI Sound is back! Display#1 is back!

??????
 
G

Gene E. Bloch

I had a sound oddity occur this morning.
MBD RealTec audio
Video Cards HD7770 (two) in crossfire.
Win 7 32

Update to video drivers ver 13.1
When update to video(and AMD video card audio) was completed,
The MBD Realtec sound drivers were activated and made default
The AMD HDMI audio output to the LCD display was inop.
On the AMD "vision engine control center", display #1 was nonexistent,
even though it's the active display and the only one installed.

Remember that there are actually three sets of audio drivers on this
P/C- Microsoft's windows drivers, Realtec drivers, and the AMD drivers.

1. Disabled the MBD audio system in BIOS
(Did not solve the problem, but did reduce the complexity.)

Went back to the AMD video driver installer, and, using custom,
uninstalled the AMD audio driver. Exited the installer.
Lo and behold, a windows notification popup said that an audio driver
was being installed (by windows)
HDMI Sound is back! Display#1 is back!

??????
I might have written 10 question marks instead of six :)

Did you leave the mbd sound disabled?

I couldn't help anyway, since this monitor doesn't have audio built-in,
so of course I don't use HDMI sound, and therefore I'm even less
informed than I might be anyway ;-)
 
C

charlie

I might have written 10 question marks instead of six :)

Did you leave the mbd sound disabled?

I couldn't help anyway, since this monitor doesn't have audio built-in,
so of course I don't use HDMI sound, and therefore I'm even less
informed than I might be anyway ;-)
I did, but on a later reboot re-enabled it.
The windows audio driver install actually installed an AMD audio driver.
Don't know if it was the current or previous version. At least it works
so far!
Only visible difference was (maybe) a slight change in windows reported
performance numbers. It's hard to tell if this is real, because the
video driver revision improved some minor video issues, at the expense
of speed. One seems to be related to clear and refresh functions. The
earlier driver version had gained some speed by short-cutting code that
was involved in removing extra left over windows that in part
under-lapped an active window. (Sometimes visible parts of the window
were not cleared.)

Part of the issues might be that the MBD uses a Realtec 1600 sound chip
instead of the more common version of the same basic chip.
The Realtec drivers are the same for the generic version, but the chip
recognition scheme must be manually tweaked to use the generic driver
install. It's usually not worth the bother.
 
D

Dave-UK

JCO said:
OS: Windows 7 with all updates;
Message: The Audio Service Is Not Running

Every time I boot the computer, my speaker system has the red "X" next to
it. However, the sound is still working just fine. If I mute it then
un-mute it, the "x" goes away. In fact, if I change the volume it also goes
away. When I mouse over the Speaker Icon (lower right corner), while the
Rec "X" is there, I get the message above.

I don't have any driver issue at all. I don't know what Service, the
message is referring too. I don't see a service called "Audio".

Obviously this is not that serious since the sound is working fine, but if
anyone has an idea, I would like to fix it.

Thanks
As Gene said, the service is called Windows Audio, and it would be worth checking
that the Startup type is set to 'Automatic'.
 
Ad

Advertisements

G

Gene E. Bloch

As Gene said, the service is called Windows Audio, and it would be worth checking
that the Startup type is set to 'Automatic'.
On my machine, the startup type is set to automatic, and it fails every
so many restarts - maybe five to eight.

When I go to the Services panel, even though the systray icon has the
red X, the Services panel shows it as running (actually Started). That's
why I click on Restart rather than Start. Then the red X goes away.
 
N

Nil

On my machine, the startup type is set to automatic, and it fails
every so many restarts - maybe five to eight.

When I go to the Services panel, even though the systray icon has
the red X, the Services panel shows it as running (actually
Started). That's why I click on Restart rather than Start. Then
the red X goes away.
If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
 
G

Gene E. Bloch

If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
You were kind enough to give me an out:

"If it happens often enough or is annoying enough..."

But if it ever reaches that level, I will refer to the note I'm about to
make of your suggestion :)

The OP should take note of your ideas also, since it happens to her or
him at every restart.
 
J

JCO

This did work even though it showed mine already started. I stopped and
restarted. I find it strange that I don't have any sound issues, it's just
the visual.

I'm wondering what the Delay Automatic setting is for. Maybe it starts the
service later which may help. This is not a fix of course because it
happens on every boot.
Thanks for the input and showing me the correct Service.


"Gene E. Bloch" wrote in message

OS: Windows 7 with all updates;
Message: The Audio Service Is Not Running

Every time I boot the computer, my speaker system has the red "X" next to
it. However, the sound is still working just fine. If I mute it then
un-mute it, the "x" goes away. In fact, if I change the volume it also
goes
away. When I mouse over the Speaker Icon (lower right corner), while the
Rec "X" is there, I get the message above.

I don't have any driver issue at all. I don't know what Service, the
message is referring too. I don't see a service called "Audio".

Obviously this is not that serious since the sound is working fine, but if
anyone has an idea, I would like to fix it.

Thanks
The service is called Windows Audio and it *is* listed in the Services
app.

My fix has been to open Services, scroll to the app, right click, and
choose Restart.

With any luck, in future I'll remember your much easier approach :)

BTW, it happens to me relatively infrequently. Lucky me, I guess.
 
J

JCO

It is set to Automatic and the service was started and running. I guess
this is why my sound always worked just fine. Something, however, is not
updating because on every boot, I get the same Red "X".

It's just a visual thing, but it does bug me.


"Dave-UK" wrote in message


JCO said:
OS: Windows 7 with all updates;
Message: The Audio Service Is Not Running

Every time I boot the computer, my speaker system has the red "X" next to
it. However, the sound is still working just fine. If I mute it then
un-mute it, the "x" goes away. In fact, if I change the volume it also
goes away. When I mouse over the Speaker Icon (lower right corner), while
the Rec "X" is there, I get the message above.

I don't have any driver issue at all. I don't know what Service, the
message is referring too. I don't see a service called "Audio".

Obviously this is not that serious since the sound is working fine, but if
anyone has an idea, I would like to fix it.

Thanks
As Gene said, the service is called Windows Audio, and it would be worth
checking
that the Startup type is set to 'Automatic'.
 
Ad

Advertisements

J

JCO

The batch file is a good idea. Plus you (me too) could put the batch file
in the "Start" menu so that it is automatic.

I still would like to solve the issue.
I tried the Automatic Delay setting but it gave me an Error 87. I really
don't know what that is so I put it back on Automatic.
Thanks

"Nil" wrote in message
On my machine, the startup type is set to automatic, and it fails
every so many restarts - maybe five to eight.

When I go to the Services panel, even though the systray icon has
the red X, the Services panel shows it as running (actually
Started). That's why I click on Restart rather than Start. Then
the red X goes away.
If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
 
J

JCO

How do you modify the batch file so that it Runs As Administrator?


"Gene E. Bloch" wrote in message

If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
You were kind enough to give me an out:

"If it happens often enough or is annoying enough..."

But if it ever reaches that level, I will refer to the note I'm about to
make of your suggestion :)

The OP should take note of your ideas also, since it happens to her or
him at every restart.
 
J

JCO

Never mind. I got it. Sorry.


"JCO" wrote in message
How do you modify the batch file so that it Runs As Administrator?


"Gene E. Bloch" wrote in message

If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
You were kind enough to give me an out:

"If it happens often enough or is annoying enough..."

But if it ever reaches that level, I will refer to the note I'm about to
make of your suggestion :)

The OP should take note of your ideas also, since it happens to her or
him at every restart.
 
J

JCO

Updated Information:
The Batch file works really well but putting in the Start Folder did not
automate like I had hoped. It must initiate to early in the boot mode
because the Red X is still displayed. Thought I would let you know.
Thanks thus far for all the help.

"Nil" wrote in message
On my machine, the startup type is set to automatic, and it fails
every so many restarts - maybe five to eight.

When I go to the Services panel, even though the systray icon has
the red X, the Services panel shows it as running (actually
Started). That's why I click on Restart rather than Start. Then
the red X goes away.
If it happens often enough or is annoying enough, you could write a
little batch file that will restart the service without you having to
slog through the menus. The batch file would say:

net stop "Windows Audio" & net start "Windows Audio"

You would need to create a shortcut with the "Run as Administrator"
option checked, and you'd have to acknowledge the security warning when
you ran it, I still think it would be easier. I had to do something
similar for a while when the network on one computer kept crashing (it
turned out to be a failing network adapter.)

Still, it shouldn't be happening in the first place. Maybe if you
reinstalled or updated the audio drivers?
 
D

Dave-UK

JCO said:
Updated Information:
The Batch file works really well but putting in the Start Folder did not
automate like I had hoped. It must initiate to early in the boot mode
because the Red X is still displayed. Thought I would let you know.
Thanks thus far for all the help.
According to Microsoft your problem is only ' cosmetic '.

http://support.microsoft.com/kb/2011656

If you've several start-up items maybe you could try stopping
them one at a time to see if that helps.
 
Ad

Advertisements

J

JCO

I have 5-items in my start menu but only have this issue with the audio that
I have to do the Stop & Start with. Yes it is only cosmetic, but I would
think it should be something that has a fix. Thanks for the article.


"Dave-UK" wrote in message


JCO said:
Updated Information:
The Batch file works really well but putting in the Start Folder did not
automate like I had hoped. It must initiate to early in the boot mode
because the Red X is still displayed. Thought I would let you know.
Thanks thus far for all the help.
According to Microsoft your problem is only ' cosmetic '.

http://support.microsoft.com/kb/2011656

If you've several start-up items maybe you could try stopping
them one at a time to see if that helps.
 
Ad

Advertisements

D

Dave-UK

JCO said:
I have 5-items in my start menu but only have this issue with the audio that
I have to do the Stop & Start with. Yes it is only cosmetic, but I would
think it should be something that has a fix. Thanks for the article.
So did you try stopping the 5 items ?
I've never had this problem with Win7 so I'm guessing it's a software issue
somewhere at start-up.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top