[SOLVED] Audio Problem WIN7 32

Discussion in 'Windows 7 Support' started by Ocean, Dec 8, 2011.

  1. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    I use ASUS R051PX Netbook. Since four days, the built-in speaker is not functioning. Expanding Sound, video and game controller in DM, shows only Icons of (i) Blue tooth hands-free audio & (ii) HSPAData card USB audio control. Realtek HD Audio Control icon is not shown. How can I get it back ? THX.
    Ocean, Dec 8, 2011
    #1
  2. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    Try installing the Realtek ALC269 Audio Driver V6.0.1.6373 Dated 2011.05.31 from HERE

    Edit: That link was for an ASUS 1015PX as in your system specs but the R051PX uses the same driver, see HERE
    Last edited: Dec 19, 2011
    TrainableMan, Dec 19, 2011
    #2
    Ocean likes this.
  3. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    It didn't resolve the problem.
    Ocean, Dec 24, 2011
    #3
  4. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    Did the driver install?

    What do you see if you go to Control Panel>Sound ... Playback Tab ? Make sure your speaker is set as default. You can also click Properties and then from the General Tab click properties again ... does it say the driver is working correctly? You can also go to configure and hit TEST.
    TrainableMan, Dec 24, 2011
    #4
    Ocean likes this.
  5. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    Merry X-Mas

    Pl see the attachment.

    Thanx.

    Attached Files:

    Ocean, Dec 25, 2011
    #5
  6. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    What is that HSPADatacard USB ? Are those external speakers? Maybe a modem? Just curious because I do not believe THAT could be your internal speaker, therefore it isn't installed.

    It says it did maintenance but it doesn't say it installed anything. I believe you should see a third item in sound, video and game controllers that says "High Definition Audio Device" but that isn't there.

    I'm really at a loss here. The only thing I can think of is that if the speaker controller inside broke then the driver probably wouldn't install because it can't see a device that needs it.

    How old is the netbook? Still under warranty?
    Have you tried ASUS support?

    Maybe others will come along with an idea to try.
    TrainableMan, Dec 25, 2011
    #6
    Ocean likes this.
  7. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    I'm curious, does anything happen if you go into the Vista subdirectory under 6373_PG322_Win7_Vista_XP and run RtlUpd.exe?
    TrainableMan, Dec 25, 2011
    #7
    Ocean likes this.
  8. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    HSPAdatacard USB - seems to be external speaker. The speaker icon at system tray overlapped by a X whenever no USB port is used . I have noticed this phenomenon as and when i disconnect 3G DATA card from USB port.

    I wonder what could be other option for sound.

    I also believe speaker controller has gone faulty from inside.

    The Netbook was purchased on Aug 2011. Yes it is still under warranty period of 1 year. No, i have not contact ASUS as i wanted to try it for myself. I think i will try reinstalling WIN7 but not sure if it has parition or else i need extra hardware.
    If this fails , i would surely call ASUS.

    Reply for Your next post.
    I could not find any <RtlUpd.exe> file in the sub-directory.

    Thanx for spending your time to sort out problem.
    Ocean, Dec 25, 2011
    #8
  9. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    OK, so the first one, your built-in networking connection is likely wi-fi w/ bluetooth and this would be for bluetooth sound (such as a bluetooth headset) and the second is your 3G Data card, so you definitely are not showing an internal speaker driver.

    As for the RtlUpd, it is under the Vista directory, see here:
    RtlUpd.jpg

    It is possible the driver just has not installed properly or it could be that it needs another driver that allows communications to the speaker driver so it still could be a driver issue. But worst case scenario is that the internal speaker is physically broken in some way.

    Since you are still under warranty I would definitely take advantage of the tech support and see if they have any ideas/suggestions or maybe some test programs to determine if it is a hardware failure.
    TrainableMan, Dec 26, 2011
    #9
    Ocean likes this.
  10. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    Hi!
    Y-day I opened DM when Window updates were finished and found that Realtek HD Audio was back in Sound Video & Games Controller. But it showed no driver was installed. Earlier I downloaded " Realtek ALC269 Audio Driver V6.0.1.6373 Dated 2011.05.31 " as suggested by you. I installed it and sound from internal speaker was back. Thx a lot for your help. Please intimate what was the root cause of this phenomenon in your opinion. Have a nice day.
    Last edited: Jan 17, 2012
    Ocean, Jan 17, 2012
    #10
  11. Ocean

    TrainableMan ^ The World's First ^ Moderator

    Joined:
    May 10, 2010
    Messages:
    7,621
    Location:
    PA, USA
    Just a guess but I would say you had a communications driver missing as well as an audio driver and that the Windows Update fixed the communications driver so that at that point the computer could see your sound card; then when you ran the Realtek driver install that fixed the Audio driver as well.

    Other less happy possibility is that there is some hardware issue such as your audio cards connection is loose and it will work sometimes but go out others.

    Let's hope it was the first thing and that now you are all fixed.
    TrainableMan, Jan 17, 2012
    #11
    Ocean likes this.
  12. Ocean

    Ocean

    Joined:
    Dec 8, 2011
    Messages:
    6
    Thanx indeed
    Ocean, Jan 18, 2012
    #12

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. shy12

    audio problem on WINDOWS 7

    shy12, Sep 25, 2009, in forum: Windows 7 Support
    Replies:
    2
    Views:
    2,146
    marcelg
    Oct 4, 2009
  2. ygeva

    Audio problem

    ygeva, May 7, 2010, in forum: Windows 7 Support
    Replies:
    2
    Views:
    1,371
    Digerati
    May 8, 2010
  3. Yousuf Khan

    HD Audio problem

    Yousuf Khan, Nov 7, 2010, in forum: alt.windows7.general
    Replies:
    8
    Views:
    1,803
    Yousuf Khan
    Nov 15, 2010
  4. iceknight

    Problem with audio

    iceknight, Feb 15, 2011, in forum: Windows 7 Support
    Replies:
    0
    Views:
    598
    iceknight
    Feb 15, 2011
  5. dhanalaxmi

    win 7 audio problem

    dhanalaxmi, Apr 11, 2013, in forum: Drivers
    Replies:
    1
    Views:
    406
    TrainableMan
    Apr 11, 2013
Loading...

Share This Page